ACM-ICPC 2018 焦作赛区网络预赛 G. Give Candies(思维+欧拉降幂)| I. Save the Room (签到)

G.

题目:

There are NN children in kindergarten. Miss Li bought them NN candies. To make the process more interesting, Miss Li comes up with the rule: All the children line up according to their student number (1…N)(1…N), and each time a child is invited, Miss Li randomly gives him some candies (at least one). The process goes on until there is no candy. Miss Li wants to know how many possible different distribution results are there.

Input

The first line contains an integer TT, the number of test case.

The next TT lines, each contains an integer NN.

1 \le T \le 1001≤T≤100

1 \le N \le 10^{100000}1≤N≤10
100000

Output

For each test case output the number of possible results (mod 1000000007).

题解:

往后推几个就可以得到方案总数为2N−12^{N-1}2 N−1
 ,但是N特别大,欧拉降幂一下即可an%mod = an%(mod-1)%mod。

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const ll mod=1e9+7;
ll quickpow(ll a,ll b)
{
    ll r=1;
    while(b)
    {
        if(b&1) r=r*a%mod;
        a=a*a%mod;
        b/=2;
    }
    return r;
}
char s[100005];
 
int main()
{
    int T;
    scanf("%d",&T);
 
    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        ll temp=0;
        for(int i=0;i<len;i++)
        {
            temp=(temp*10+s[i]-'0')%(mod-1);
        }
        temp--;
        if(temp<0) temp=mod-1;
        printf("%lld\n",quickpow(1LL*2,temp));
    }
    return 0;
}

I.

题目:

Bob is a sorcerer. He lives in a cuboid room which has a length of AA, a width of BB and a height of CC, so we represent it as AA * BB * CC. One day, he finds that his room is filled with unknown dark energy. Bob wants to neutralize all the dark energy in his room with his light magic. He can summon a 11 * 11 * 22 cuboid at a time to neutralize dark energy. But the cuboid must be totally in dark energy to take effect. Can you foresee whether Bob can save his room or not?

Input

Input has TT test cases. T \le 100T≤100

For each line, there are three integers A, B, CA,B,C.

1 \le A, B, C \le 1001≤A,B,C≤100

Output

For each test case, if Bob can save his room, print"Yes", otherwise print"No".

样例输入复制

1 1 2
1 1 4
1 1 1

样例输出复制

Yes
Yes
No

题目来源

ACM-ICPC 2018 焦作赛区网络预赛


题解:

同样是一道水题。

此题的思路就是说,现在提供一个长宽高分别为a,b,c的长方体,判断能不能用1*1*2的长方体将其填满。

因为是1*1*2所以比较简单,只有一种情况下不成立那就是当最后剩余一个1*1*1的块时候。即体积只要能够满足为偶数即可。


代码:

#include <stdio.h>
int main(){
	int a,b,c,d;
	while(scanf("%d %d %d",&b,&c,&d)!=EOF){
		if(b*c*d%2!=0){
			printf("NO\n");
		}else{
			printf("YES\n"); 
		}
	} 
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

12 26 25

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值