Secrete Master Plan HDU - 5540

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×22×2 matrix, but Fei didn't know the correct direction to hold the sheet. What a pity! 

Given two secrete master plans. The first one is the master's original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket. 

Input

The first line of the input gives the number of test cases, T(1≤T≤104)T(1≤T≤104). TT test cases follow. Each test case contains 4 lines. Each line contains two integers ai0ai0 and ai1ai1 (1≤ai0,ai1≤1001≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rd3rd and 4th4th line stands for the plan Fei opened.

Output

For each test case, output one line containing "Case #x: y", where x is the test case number 
(starting from 1) and yy is either "POSSIBLE" or"IMPOSSIBLE" (quotes for clarity).

Sample Input

4
1 2
3 4
1 2
3 4

1 2
3 4
3 1
4 2

1 2
3 4
3 2
4 1

1 2
3 4
4 3
2 1

Sample Output

Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE

AC代码(其实就是矩阵转置问题去讨论他会和转置后的哪一个相同)

Select Code

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int a[5], b[5];
bool check()
{
    if(a[0]==b[0]&&a[1]==b[1]&&a[2]==b[2]&&a[3]==b[3]) return 1;
    if(a[0]==b[1]&&a[1]==b[3]&&a[2]==b[0]&&a[3]==b[2]) return 1;
    if(a[0]==b[3]&&a[1]==b[2]&&a[2]==b[1]&&a[3]==b[0]) return 1;
    if(a[0]==b[2]&&a[1]==b[0]&&a[2]==b[3]&&a[3]==b[1]) return 1;
    return 0;
}
int main()
{

    int k, t, i;
    scanf("%d",&t);
    for(k = 1;k<=t;k++)
    {
        for(i = 0;i<4;i++) scanf("%d",&a[i]);
        for(i = 0;i<4;i++) scanf("%d",&b[i]);
        if(check()) printf("Case #%d: POSSIBLE\n",k);
        else printf("Case #%d: IMPOSSIBLE\n",k);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: 我们可以使用Ansible来编写一个脚本来批量部署OpenStack,这个脚本可以完成以下任务: 1)安装OpenStack所需的软件包 2)创建OpenStack组件所需的配置文件 3)运行OpenStack各个组件 4)检查OpenStack安装是否成功 5)启动OpenStack各个组件 6)收集OpenStack部署的统计信息。 ### 回答2: 要编写一个OpenStack的批量部署脚本,可以使用Python编程语言。下面是一个简单的实现示例: ```python import os # 定义部署函数 def deploy_openstack(): # 安装依赖 os.system('apt-get update') os.system('apt-get install -y python-dev python-pip') os.system('pip install ansible') # 克隆 OpenStack-Ansible 仓库 os.system('git clone https://github.com/openstack/openstack-ansible.git') # 配置 OpenStack-Ansible os.chdir('openstack-ansible') os.system('cp etc/openstack_deploy/openstack_user_config.yml.example etc/openstack_deploy/openstack_user_config.yml') # 修改配置文件 os.system('sed -i "s/# admin_password: secrete/admin_password: mypassword/g" etc/openstack_deploy/openstack_user_config.yml') os.system('sed -i "s/# neutron_external_interface: '{{ physical_external_interface }}'/neutron_external_interface: 'eth0'/g" etc/openstack_deploy/openstack_user_config.yml') # 安装 OpenStack-Ansible os.system('scripts/bootstrap-ansible.sh') # 部署 OpenStack os.system('scripts/run-playbooks.sh') # 调用部署函数 deploy_openstack() ``` 这个脚本会执行以下操作: 1. 安装必要的依赖 2. 克隆 OpenStack-Ansible 仓库 3. 配置 OpenStack-Ansible 4. 修改配置文件中的一些参数,比如管理员密码和外部网络接口 5. 安装 OpenStack-Ansible 6. 运行Playbooks,开始部署 OpenStack 请注意,该脚本仅为示例,实际部署可能需要根据环境和需求进行调整和扩展。 ### 回答3: 要编写一个OpenStack的批量部署脚本,需要考虑以下几个步骤。 第一步是安装操作系统。脚本可以使用自动化工具,如PXE或Kickstart来安装操作系统。这个步骤可以使用网络安装或基于ISO镜像的安装。 第二步是安装OpenStack所需的依赖软件。这包括Python、MySQL数据库、RabbitMQ消息队列等。脚本可以检查并安装所需的软件包,并配置相应的环境变量和依赖关系。 第三步是配置网络。这包括设置网络接口、创建网桥、配置IP地址和网络路由等。脚本可以通过调用网络配置命令和编辑配置文件来完成这些操作。 第四步是安装和配置OpenStack服务。这包括Nova计算服务、Neutron网络服务、Glance镜像服务、Cinder块存储服务等。脚本可以使用类似于上一步的方法来安装和配置这些服务,并根据需求进行相应的设置。 第五步是创建和配置OpenStack的虚拟机实例。脚本可以使用命令行工具或API来创建和配置虚拟机实例,并设置其属性如虚拟硬件、网络连接等。 最后一步是测试和验证部署。脚本可以运行一系列测试用例,如创建虚拟机、访问网络、上传和下载镜像等,以确保OpenStack的正确功能。 综上所述,可以编写一个包含上述步骤的批量部署脚本,以简化和加速OpenStack的部署过程,提高效率和准确性。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值