1013. Battle Over Cities (25)(C++)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

题目大意:去掉一个连通图中的一个节点,剩下的节点还能构成连通图吗,不能的话,最少需要几条路将其联系在一起?(其实就是求连通图被分成了几块,即连通分量的个数)。

解题思路:直接遍历图就好了,就直接当那个丢失的点已经被访问过了,dfs最方便了,嘻嘻——

DFS

#include <iostream>
#include <vector>
using namespace std;
int n, m, k;
vector<int>road[1005];
bool visit[1005];
void dfs(int index){
	visit[index] = true;
	for(int i = 0; i < road[index].size(); ++ i)
		if(visit[road[index][i]] == false)
			dfs(road[index][i]);
}
int main(){
	scanf("%d %d %d",&n,&m,&k);
	for(int i = 0; i < m; ++ i){
		int a, b;
		scanf("%d %d",&a,&b);
		road[a].push_back(b);
		road[b].push_back(a);
	}
	for(int i = 0; i < k; ++ i){
		fill(visit, visit + 1005, false);
		int temp, cnt = -1;
		scanf("%d",&temp);
		visit[temp] = true;
		for(int i = 1; i <= n; ++ i){
			if(visit[i] == false){
				++ cnt;
				dfs(i);
			}
		}
		printf("%d\n", cnt);
	}
}

并查集

#include <iostream>
#include <vector>
using namespace std;
struct Edge
{
    int from, to;
};
int n, m, k, temp;
int father[1005];
int findfather(int x){
    if(x == father[x])
        return x;
    int temp = findfather(father[x]);
    father[x] = temp;
    return temp;
}
int countFather(){
    int cnt = -2;
    for(int i = 1; i <= n; ++ i)
        if(i == father[i])
            cnt += 1;
    return cnt;
}
int main(){
    scanf("%d %d %d",&n,&m,&k);
    vector<Edge>edges(m);
    for(int i = 0; i < m; ++ i)
        scanf("%d %d",&edges[i].from,&edges[i].to);
    for(int i = 0; i < k; ++ i){
        for(int j = 1; j <= n; ++ j)
            father[j] = j;
        scanf("%d", &temp);
        for(Edge e : edges){
            int ua = findfather(e.from), ub = findfather(e.to);
            if(ua != temp && ub != temp && ua != ub)
                father[ua] = ub;
        }
        printf("%d\n", countFather());
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值