1047. Student List for Course (25)(C++)

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

 

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

解题思路:之前有道题是输入每个课有哪些学生选,然后给出某些学生选的课。这题则相反,也相对容易一些。

值得注意的可能就是cmp的编写。

#include <iostream>
#include <vector>
#include <string.h>
#include <algorithm>
using namespace std;
char name[40005][5];
int cmp(int a,int b){
	return strcmp(name[a],name[b])<0;
}
int main(){
	int m,n;
	scanf("%d %d",&m,&n);
	std::vector<int>v[2005];
	for(int i=0;i<m;++i){
		scanf("%s",name[i]);
		int num;
		scanf("%d",&num);
		for(int j=0;j<num;++j){
			int y;
			scanf("%d",&y);
			v[y-1].push_back(i);
		}
	}
	for(int i=0;i<n;++i){
		printf("%d %d\n",i+1,v[i].size());
		sort(v[i].begin(), v[i].end(),cmp);
		for(int j=0;j<v[i].size();++j){
			printf("%s\n",name[v[i][j]]);
		}
	}
	return 0;
}

也同样可以使用1039的hash思想

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int getid(char *name){
    int id=0;
    for(int i=0;i<3;i++)
        id=id*26+(name[i]-'A');
    id=id*10+(name[3]-'0');
    return id;
}
int main(){
    int n,k;
    cin>>n>>k;
    std::vector<int> course[k+1];
    for(int i=0;i<n;i++){
        char name[5];
        int cnt,temp,tempid;
        scanf("%s %d",name,&cnt);
        tempid=getid(name);
        for(int j=0;j<cnt;j++){
            scanf("%d",&temp);
            course[temp].push_back(tempid);
        }
    }
    for(int i=1;i<=k;i++){
        int num=course[i].size();
        printf("%d %d\n",i,num);
        sort(course[i].begin(),course[i].end());
        for(int j=0;j<num;j++){
            int a,b,c,d,temp;
            temp=course[i][j];
            d=temp%10;temp/=10;
            c=temp%26;temp/=26;
            b=temp%26;temp/=26;
            a=temp;
            printf("%c%c%c%c\n",a+'A',b+'A',c+'A',d+'0');
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值