1059 Prime Factors(25 分)(C++)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意:将一个数分解为若干素数之积;

解题思路:建立素数表

#include <iostream>
#include <vector>
using namespace std;
int x;
vector<bool>isprime(500000,true);
int main(){
    int i,j,cnt=1;
    bool flag=true;
    for(i=2;i<5000;i++)
        for(j=i*i;j<500000;j+=i)
            isprime[j]=false;
    cin>>x;
    printf("%d=",x);
    if(x==1)
      cout<<1;
    while(x>1){
        cnt++;
        while(isprime[cnt]==false)
            cnt++;
        int num=0;
        while(x%cnt==0){
            x/=cnt;
            num++;
        }
        if(num>=1){
            if(flag==false)
                printf("*");
            printf("%d",cnt);
            if(num>1)
                printf("^%d",num);
            flag=false;
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值