1144 The Missing Number(20 分)(C++)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

解题思路:计数排序思想,但是注意visit数组的大小为n+2,因为最多可能出现的正数为1-n(共n个),加上0的存在,以及预留一个一定没有访问到的正数,为0-n+1(共n+2)

#include <iostream>
#include <vector>
using namespace std;
int main(){
    int n, temp, ans = 1;
    cin>>n;
    std::vector<int> visit(n + 2, true);
    for(int i = 0; i < n; ++ i){
        scanf("%d",&temp);
        if(temp >= 1 && temp <= n)
            visit[temp] = false;
    }
    while(visit[ans] == false)
        ++ ans;
    printf("%d",ans);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值