一道很好的贪心题 Gone Fishing

Gone Fishing

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch. 
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected. 
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

题意 就不想翻译了,英语渣渣表示抗议........................

思路:我们可以直接在开始的时候就减去路程的时间,可以将钓鱼的小哥当作在每个池塘之间瞬移,每次都掉鱼数最多的池塘,对池塘进行枚举,看 只吊第一个池塘的鱼能有多少个,然后再看 吊第一个和第二个,.....以此来枚举求出最多的数量记录下来,  可以使用优先队列 存,这样每次都能按要求弹出.

代码:

#include<queue>
#include<stdio.h>
using namespace std;
int fis[10005],t[100005],d[100005];
int time1[100005];
int n,h;
struct node{
    int fish,id,tim;
    bool operator < (const node & a)const{
        return fish == a. fish? id > a.id:fish < a.fish;
    }
};
void solve()
{


    int maxn = -10000;
    int num;

    for(int i = 0; i < n ;i++){// 从第一个池塘开始枚举
        priority_queue<node> q;
        int  time = h*60;
        time -= t[i]*5; // 减去路程上花的时间
    
        for(int j = 0; j <= i; j++ ){//将枚举的池塘以此压入队列中
            node next;

            next.fish = fis[j];
          
            next.id = j;// 方便最后输出和排序
            next.tim = 0;
            q.push(next);
        }
        int sum = 0;
        while(time > 0){//在规定的时间内,吊枚举的池塘的鱼求出最大值,并求出来每个池塘的时间
            node next = q.top();
            q.pop();
            sum += next.fish;
            //next.fish -= d[next.id];
            next.tim += 5;
            time -= 5;
            if(next.fish) next.fish -= d[next.id];
            if(next.fish < 0) next.fish = 0;
          
            q.push(next);
        }
        if(sum > maxn){//判断是否是最大的
            maxn = sum;
            num = i;//记录到哪个池塘鱼最多,之后的鱼塘停留的时间就是0;
            while(!q.empty()){
                node next = q.top();
                q.pop();
                time1[next.id] = next.tim;
               // cout << next.id<<" "<< next.tim << endl;
            }
        }
    }
    for(int i = 0; i <= num; i++){
        if(i == 0) printf("%d",time1[i]);
        else printf(", %d",time1[i]);
    }
    for(int i = num + 1; i < n; i++){
        printf(", 0");
    }
    printf("\n");
    printf("Number of fish expected: %d\n",maxn);
}
int main()
{

    while(~scanf("%d",&n)&&n){
        scanf("%d",&h);
        for(int i = 0; i < n; i++){
            scanf("%d",&fis[i]);
        }
        for(int i = 0; i < n; i++){
            scanf("%d",&d[i]);
        }
        t[0] = 0;
        for(int i = 1; i < n; i++){
            int x;
            scanf("%d",&x);
            t[i] = t[i - 1] + x;
        }
        solve();
        printf("\n");
    }
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值