HDU Problem D [ Humble number ]——基础DP丑数序列

Problem D

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 3
Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. <br><br>Write a program to find and print the nth element in this sequence<br>
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.<br>
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.<br>
 

Sample Input
 
 
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
 
 
The 1st humble number is 1.
The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

==========================================

        想ac,英语还是得过关啊;其次,到底什么是动规。。。。。。

        思路:任意丑数的因数一定由2、3、5、7构成,反过来由2、3、5、7作为因数构成的数一定是丑数,所以我们先做个预处理,即用1、2、3......(丑数序列的第一个数)分别乘以2、3、5、7并把得到的数按升序排列,而为了满足递增数列这一要求,我们分别为2、3、5、7定义一个变量并初始为“1”,每次用变量乘以对应的数,取四个结果中最小的那个作为新得到的丑数,然后对应数据的对应变量+1,以此类推。。。(当然,我们完全用小顶堆优先队列来完成这项操作)。

        呃,最后还有输出内容的问题,即st、nd、rd、th的规律,见代码吧。

AC代码:(非优先队列)

#include<bits/stdc++.h>
using namespace std;
int f[6001];
int minn(int a,int b,int c,int d)
{
    return min(min(min(a,b),c),d);
}
int main()
{
    int a,b,c,d;
    a=b=c=d=1;
    int i=1;
    f[1]=1;
    while(i<=5842)//先做个预处理。
    {
        ++i;
        f[i]=minn(f[a]*2,f[b]*3,f[c]*5,f[d]*7);
        if(f[i]==f[a]*2)a++;//都用if,因为可能有重复解。
        if(f[i]==f[b]*3)b++;
        if(f[i]==f[c]*5)c++;
        if(f[i]==f[d]*7)d++;
    }
    int n;
    while(cin>>n&&n)
    {
        if(n%10==1&&n%100!=11)
            cout<<"The "<<n<<"st humble number is "<<f[n]<<"."<<endl;
        else if(n%10==2&&n%100!=12)
            cout<<"The "<<n<<"nd humble number is "<<f[n]<<"."<<endl;
        else if(n%10==3&&n%100!=13)
            cout<<"The "<<n<<"rd humble number is "<<f[n]<<"."<<endl;
        else
            cout<<"The "<<n<<"th humble number is "<<f[n]<<"."<<endl;
    }
    return 0;
}

The end;

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值