HDU 1394 Minimum Inversion Number 最小逆序对数(树状数组求逆序对+数论知识)

题目描述:

Minimum Inversion Number

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10

1 3 6 9 0 8 5 7 4 2

Sample Output

16

题意概括:

      给出N(小于等于5000)个数的序列,作如下变化,每次将第一个元素放到末尾位置,

总共可以产生N 中排列方式,其中每种排列方式对应序列都可以求出自己对应的逆序对数,

求这N个逆序对数中的最小值。

思路:

        利用树状数组,我们可以很轻松的NlogN求出原序列的逆序对数SUM,且5000数据量不用离散化,

考虑每次变化对原序列逆序对数产生的贡献,即减去损失的加上新获得的 等于 后n-1个元素中比当前

arr【1】小的+后N-1比当前arr【1】大的。

思考:

     由于本题所给序列是0~n-1的连续自然数,所以很容易求出,如果不是连续的,可以考虑预处理一下,

相当于离散化?

代码实现:

#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
#define LL long long
#define par pair<int,int>
#define INF 0x3f3f3f3f
using namespace std;
const int N=2e5+100;

int arr[N],c[N];
void add(int x,int v,int n){
	for(;x<=n;x+=x&-x){
		c[x]+=v;
	}
}
int query(int x){
	int ans=0;
	for(;x;x-=x&-x){
		ans+=c[x];
	}
	return ans;
}
int main(){
	int n,sum=0,ans,tmp;
	while(scanf("%d",&n)!=EOF){
		sum=0;
		ans=INF;
		memset(c,0,sizeof(c));
		memset(arr,0,sizeof(arr));
		
		for(int i=1;i<=n;i++)scanf("%d",&arr[i]),arr[i]+=1;
		
		for(int i=1;i<=n;i++){
			
			sum+=i-1-query(arr[i]);
			add(arr[i],1,n);
			
		}
		ans=sum;
		for(int i=1;i<n;i++){
			sum+=n+1-2*arr[i];
			ans=min(ans,sum);
		}
		
		printf("%d\n",ans);
	}
	return 0;
	
	
	
}

THE END;

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值