hdoj 1532 Drainage Ditches 题解(网络流 >最大流详解)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22614    Accepted Submission(s): 10830


 

Problem Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

 

 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

 

 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

 

 

Sample Input

 

5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10

 

 

Sample Output

 

50

 

题意:给出n个河流,m个点,以及每个河流的流量,求从1到m点的最大流量。

 

分析:最裸的网络流题目

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=220;
const int inf=0x3f3f3f3f;
struct node{
    ll t,cap,flow,nex;
}e[N*N];
int head[N],vis[N],cut;
void add(int u,int v,int cap)
{
    e[cut]=node{v,cap,0,head[u]};
    head[u]=cut++;//编号
    e[cut]=node{u,0,0,head[v]};//反向边 0 0
    head[v]=cut++;
}
int d[N];//层次图
bool bsf(int s,int t)//深度 构造d[]数组;
{
    memset(d,0,sizeof d);//初始化数组d[];
    queue<int>q;//队列广度搜索
    q.push(s);//源点出发
    d[s]=1;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];~i;i=e[i].nex)
        {
            int v=e[i].t;
            if(d[v]==0&&e[i].cap>e[i].flow)//没遍历过&&可通过
            {
                d[v]=d[u]+1;//层次+
                q.push(v);
            }
        }
    }
   return d[t]>0;//可以到达汇点//存在增广路

}
ll dfs(int s,int t,ll minedge)//寻找路径之中最小的流
{
    if(s==t) return minedge;
    ll flow=0;
    for(int i=vis[s];~i;i=e[i].nex)
    {
        int v=e[i].t;
        if(d[v]==d[s]+1&&e[i].cap>e[i].flow)
        {//层次对&&可通流
            ll temp=dfs(v,t,min(minedge-flow,e[i].cap-e[i].flow));
            //最小可行流
            e[i].flow+=temp;//流量增加
            e[i^1].flow-=temp;//反向减流
            flow+=temp;//flow已分配的流量
            if(flow==minedge) return flow;
            //已达到祖先的最大流,无法再大,剪枝
        }
    }
    if(flow==0) d[s]=0;//此点已无流,标记掉
    return flow;
}
ll dinic(int s,int t)
{
    ll maxflow=0;
    while(bsf(s,t))//有增广路
    {
        memcpy(vis,head,sizeof head);
        maxflow+=dfs(s,t,inf);
    }
    return maxflow;
}
int main()
{
    int n,m,s,t,l;
    while(cin>>m>>n)//m边 n点
    {
        memset(head,-1,sizeof head);
        cut=0;
        for(int i=0;i<m;i++)
        {
            cin>>s>>t>>l;
            add(s,t,l);
        }
        int ans=dinic(1,n);
        cout<<ans<<"\n";
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值