pat甲级 1093 Count PAT's (左右数组处理)(简单模拟)

1093 Count PAT's (25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

/**
本题题意 判断 一个字符串 含有多少个PAT
思路:
    1.遍历字符串时, 求出A之前的P个数 num1 和 A之后的T的个数 num2, 将
    它们相乘就是这个A对应的所有pat组合个数, 找到一个字符串中所有这样的情况
    并相加 就是所有PAT的个数
    2.设定两个数组 left[i] 记录的是 第i个元素的左边P的最大数目
      当s[i - 1]为p时 left[i] = left[i] + 1, 否则 , left[i] = left[i + 1]
      同理 T也可以这样做(当然也可以更加简便, 不用数组存储, 直接设定两个变量)
    3.本题设定结果 mod 1000000007  但是并不能最后直接mod ,会导致结果错误,
    需要在累加时进行mod
    
**/

 

//设定两个数组的处理:

#include<iostream>
using namespace std;
const int maxsize = 1e5 + 5; 
string s;
int left_p[maxsize], right_t[maxsize];
int main(){
	getline(cin, s);
	int length = s.size();
	left_p[0] = 0;
	right_t[length - 1] = 0;
	for(int i = 1; i < length; i++){
		if(s[i - 1] == 'P')
			left_p[i] = left_p[i - 1] + 1;
		else
			left_p[i] = left_p[i - 1];
		if(s[length - i] == 'T')
			right_t[length - i - 1] = right_t[length - i] + 1;
		else
			right_t[length - i - 1] = right_t[length - i];
	}
	int sum = 0;
	for(int i = 0; i < length; i++){
		if(s[i] == 'A')
			sum = (sum + (left_p[i] * right_t[i])) % 1000000007;
	}
	printf("%d\n", sum); 
	return 0;
}

 

设定一个数组的处理:

#include<iostream>
using namespace std;
const int maxsize = 1e5 + 5;
const int mod = 1000000007;
string s;
int left_p[maxsize]; //自定义的left 变量与库中重名;
int main(){
	getline(cin , s);
	int n = s.size();
	for(int i = 1; i < n; i++){
		if(s[i - 1] == 'P')
			left_p[i] = left_p[i - 1] + 1;
		else
			left_p[i] = left_p[i - 1];
	}
	int right = 0, sum = 0;
	for(int i = n - 1; i >= 0; i--){
		if(s[i] == 'T')
			right++;
		if(s[i] == 'A'){
			sum = (sum + (left_p[i] * right)) % mod;
		} 
	}
	printf("%d\n", sum % mod);
	return 0;
}

设计两个变量的处理:

#include<iostream>
using namespace std;
string s;
int main(){
	getline(cin, s);
	int pcnt = 0, tcnt = 0, sum = 0;
	for(int i = 0; i < s.size(); i++){
		if(s[i] == 'P')
			pcnt++;
	}
	for(int i = s.size() - 1; i >= 0; i--){
		if(s[i] == 'T')
			tcnt++;
		else if(s[i] == 'P')
			pcnt--;
		else if(s[i] == 'A')
			sum = (sum + tcnt * pcnt) % 1000000007;
	}
	printf("%d\n", sum);
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值