1093 Count PAT's

1093 Count PAT's (25 point(s))

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

计算有几个pat,例子中给出的是appapt,其中有两个pat,观察可以发现规律,对于每个a,其左边x个P,右边y个T,则,pat的个数就是x*y; 由此,得到该题的解题思路:

1、第一趟从前往后遍历,得到对于位置i,i左边包括其自身有多少个p,

2、第二趟从后往前遍历,对于当前位置,得到右边共有多少个t,若是为A,则计数增加。

#include <cstdio>
#include <cstring>
#define MaxSize 100010
typedef long long LL;
int main()
{
	int nump[MaxSize];
	int numt[MaxSize];
	char str[MaxSize];
	int i,n;
	LL count=0;
	scanf("%s",&str);
	n=strlen(str);
	if(str[0]=='P')
		nump[0]=1;
	else 
		nump[0]=0;
	for(i=1;i<n;i++)
	{
		if(str[i]=='P')
			nump[i]=nump[i-1]+1;
		else
			nump[i]=nump[i-1];

	}
	numt[n]=0;
	for(i=n-1;i>=0;i--)
	{
		if(str[i]=='T')
			numt[i]=numt[i+1]+1;
		else
			numt[i]=numt[i+1];
		if(str[i]=='A' && i>0)
			count=(count+numt[i]*nump[i])%1000000007;
	}
	printf("%lld",count);
	

}

 

其实 在计算t的时候不需要再用数组了,可以直接用一个int值的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值