uva7292Refract Facts(二分)

A submarine is using a communications laser to send a message to a jet cruising overhead. The sea
surface is flat. The submarine is cruising at a depth d below the surface. The jet is at height h above
the sea surface, and a horizontal distance x from the sub. The submarine turns toward the jet before
starting communications, but needs to know the angle of elevation, φ, at which to aim the laser.
When the laser passes from the sea into the air, it is refracted (its path
is bent). The refraction is described by Snell’s law, which says that light
approaching the horizontal surface at an angle θ1, measured from the vertical,
will leave at an angle θ2, given by the formula
sin θ1/sin θ2=n1/n2
where n1 and n2 are the respective refraction indices of the water and air.
(The refraction index of a material is inversely proportional to how fast light
can travel through that material.)
Input
Each test case consists of a single line of input containing 5 space-separated floating point numbers:
• d, the depth of the submarine (specifically, of the laser emitter) in feet, 1 ≤ d ≤ 800
• h, the height of the plane in feet, 100 ≤ h ≤ 10, 000
• x, the horizontal distance from the sub to the plane in feet, 0 ≤ x ≤ 10, 000
• n1, the refractive index of water, 1.0 < n1 ≤ 2.5
• n2, the refractive index of air, 1.0 ≤ n2 < n1
Input ends with a line containing 5 zeroes (0 0 0 0 0).
Output
For each test case, print a single line containing the angle of elevation φ at which the submarine should
aim its laser to illuminate the jet.
The angle should be displayed in degrees and rounded to the closest 1/100 of a degree. Exactly two
digits after the decimal point should be displayed.
Sample Input
600 600 1000 1.333 1.01
600 1200 4000 1.5 1.01
400 100 10000 2.5 1.01
0 0 0 0 0
Sample Output
44.37
11.51
2.30

在这里插入图片描述
如图,飞机到海平面的高度为h,海平面到潜艇的高度为d,飞机与潜艇之间的水平距离为x,已知,hdxn1n2,求与θ1互余的角
如果列方程求解的话,这是个四次的方程,可以通过二分来不断缩小角的范围求,如果fai大,对应的H就会大于h,所以fai要变小

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <map>
#include<stack>
using namespace std;
#define eps 0.001
#define PI acos(-1.0)
double d,h,x,n1,n2;
double mid(double l,double r)
{
    double fai,seta1,seta2,sinseta1,sinseta2,H;
    double y;
    while(r-l>eps)
    {
        fai=(l+r)/2.0;
        y=d/tan(fai*PI/180);
        sinseta1=y/(sqrt(y*y+d*d));
        sinseta2=n2*sinseta1/n1;
        H=(x-y)/tan(asin(sinseta2));
        if(H>h)
            r=fai;
        else
            l=fai;
    }
    return fai;
}

int main()
{
    double l,r;
    while(scanf("%lf %lf %lf %lf %lf",&d,&h,&x,&n1,&n2)!=EOF)
    {
        if(d==0&&h==0&&x==0&&n1==0&&n2==0)
            break;
        l=0;
        r=90;

        printf("%.2lf\n",mid(l,r));

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值