【蓝桥杯】 算法训练 最短路

问题描述

给定一个n个顶点,m条边的有向图(其中某些边权可能为负,但保证没有负环)。请你计算从1号点到其他点的最短路(顶点从1到n编号)。

输入格式

第一行两个整数n, m。

接下来的m行,每行有三个整数u, v, l,表示u到v有一条长度为l的边。

输出格式

共n-1行,第i行表示1号点到i+1号点的最短路。

样例输入

3 3
1 2 -1
2 3 -1
3 1 2

样例输出

-1
-2

数据规模与约定

对于10%的数据,n = 2,m = 2。

对于30%的数据,n <= 5,m <= 10。

对于100%的数据,1 <= n <= 20000,1 <= m <= 200000,-10000 <= l <= 10000,保证从任意顶点都能到达其他所有顶点。

#include <iostream>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <string>
#include <set>
#include <cstdio>
using namespace std;

#define inf 0x3f3f3f3f

int n,m;

struct edge{
	
	int u;
	int v;
	int cost;
};

const int MAX_E = 200005;

const int MAX_V = 20005;

edge es[MAX_E];

int d[MAX_V];

void shortest_path(int s){
	
	for(int i=1;i<=n;i++){
		
		d[i] = inf;
	}
	
	d[s] = 0;
	
	while(true){
		
		bool update = false;
		for(int i=0;i<m;i++){
			
			edge e = es[i];
			if(d[e.u] != inf && d[e.v] > d[e.u] + e.cost){
				
				d[e.v] = d[e.u] + e.cost;
				update = true;
			}
		}
		
		if(!update){
			
			break;
		}
	}
	
}

int main(){
	
	ios::sync_with_stdio(false);
	
	cin>>n>>m;
	
	for(int i=0;i<m;i++){
		
		int a,b,c;
		cin>>a>>b>>c;
		es[i].u = a;
		es[i].v = b;
		es[i].cost = c;
	}
	
	shortest_path(1);
	
	for(int i=2;i<=n;i++){
		
		cout<<d[i]<<endl;
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值