HDU 2609 How many(最小表示法+set)

题目链接:

       HDU 2609 how many

题目:

                                           How many

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3251    Accepted Submission(s): 1446


Problem Description
Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.
 

Input
The input contains multiple test cases.
Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').
 

Output
For each test case output a integer , how many different necklaces.
 

Sample Input
 
 
4011011001001001141010010110000001
 

Sample Output
 
 
12


题目分析:

题目大意:

给你n个(n <10000个)项链,项链的长度不会超过100个,告诉我总共有多少种项链(如果两个项链可以通过旋转相等,我们说这两个项链是有的)。表示一条项链,你可以旋转它0.0110→1100→1001→0011→0110都是这一条。

算法思想:

将每个字符串转换成最小串,然后放在设置里面去重。


最小表示法:

最小表示法与kmp算法一样都可以解决字符串匹配问题,但效率更高,代码短,作用更大。 
最小表示法就是一个字符串的最小字典序。 

最小表示法详讲下面推荐我看过的两个:

       ① http://blog.csdn.net/cillyb/article/details/78058174

       ② http://blog.csdn.net/slime_kirito/article/details/49022313


AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
using namespace std;
int length;
char s[10001],t[10001];
set<string>str;

int minr(char *c)
{
    int i=0,j=1,k=0,tmp;
    while(i<length && j<length && k<length)
    {
        tmp=c[(i+k)%length]-c[(j+k)%length];
        if (tmp == 0)
            k++;
        else
        {
            if (tmp > 0)
                i+=k+1;
            else
                j+=k+1;
            if (i==j)
                j++;
            k=0;
        }
    }
    return min(i,j);
}

void getSet(char *c)
{
    c[length/2]='\0';
    str.insert(c);
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        str.clear();
        for (int i=0; i<n; i++)
        {
            scanf("%s",t);
            strcpy(s,t);
            strcat(s,t);
            length=strlen(s);
            int k=minr(s);
            getSet(s+k);
        }
        cout << str.size() <<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值