51Nod 2165 ProjectEuler 4 c/c++题解

题目描述

如果一个数字从左向右读和从右向左读结果一样,我们称他为回文数。
由2个2位整数乘法能能到的最大的回文数 9009=91×99
输入n,求由2个n位整数乘法能能到的最大的回文数。
输入
输入1个数n(2 <= n <= 4)
输出
输出一个数,对应2个n位整数乘法能能到的最大的回文数。
输入样例
2
输出样例
9009

题解:

我先是枚举出现的结果,然后再if输出…

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll  INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e6+5;
int n;

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    while(cin >> n)
    {
        /*
        int low;
        int high;
        if(n == 2)
        {
            low = 10;
            high = 99;
        }
        else if(n == 3)
        {
            low  = 100;
            high = 999;
        }
        else if(n == 4)
        {
            low  = 1000;
            high = 9999;
        }
        vector <int> res;
        for(int i = high; i >= low; i--)
        {
            for(int j = high; j >= low; j--)
            {
                res.push_back(i*j);
            }
        }
        sort(res.begin(),res.end());
        for(auto it = res.rbegin(); it != res.rend(); it++)
        {
            int len = 0;
            int tmp = *it;
            while(tmp)
            {
                tmp /= 10;
                len++;
            }
            char data[20];
            sprintf(data,"%d",*it);
            int ans = 0;
            for(int i = 0; i < len/2; i++)
            {
                if(data[i] == data[len-1-i])
                    ans++;
            }
            if(ans == len/2)
            {
                cout << *it << endl;
                break;
            }
        }
        */
        if(n == 2)
        {
            cout << 9009 << endl;
        }
        if(n == 3)
        {
            cout << 906609 << endl;
        }
        if(n == 4)
        {
            cout << 99000099 << endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值