Lotto HDU - 1342【DFS】【讲解PE原因】

这是一道水题,但是PE却折磨了我近两个小时的时间让我反复读题终于明白了。

In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S. 
InputThe input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k. 
OutputFor each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 
Sample Input
7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0
Sample Output
1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34


        这道题熟悉DFS的人都会做,但你会发现你的答案表面上和题目给的样例相同但为什么就是PE了呢?这可就迷惑了我半天,后来我才发现给的样例中的那一行空行可不简单,题目除了要求我们输出那规定的行数之外,还要求除了测试的第一条后面的几条前都需要有换行符,这没准才是这道题惨绝人到的理由吧。

完整代码

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n;
int a[100];
int b[100];
bool cmp(int r1, int r2)
{
    return r1<r2;
}
void dfs(int b_i, int a_i, int len)
{
    if(len==6)
    {
        for(int i=0; i<5; i++)
        {
            cout<<b[i]<<" ";
        }
        cout<<b[5]<<endl;
        return;
    }
    if(len>6) return;
    if(a_i>=n) return;
    b[b_i]=a[a_i];
    dfs(b_i+1, a_i+1, len+1);
    dfs(b_i, a_i+1, len);
}
int main()
{
    int num=0;
    while(scanf("%d",&n)&&n)
    {
        if(num) cout<<endl;
        for(int i=0; i<n; i++)
        {
            scanf("%d%*c",&a[i]);
        }
        sort(a, a+n, cmp);
        dfs(0, 0, 0);
        ++num;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值