Discovering Gold【概率DP、期望DP】

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

 

这道题还真是有点意思,我最初想法就是dp[i+j]+=dp[i]/min(N-i, 6),后来怎么样都是过不了第三个测试样例,当时一想,好像并没有什么问题......但又一想好像并不大对,因为期望值的话,我们如果遍历的话,只有最后一个值是确定的,其余的值是从最后一个开始逆推回来,但是正序推过去就不行,因为当前状态下的期望是由所有后继状态的输出值(期望)乘以其到达它的概率之和得到,反之,如果正序推会出现什么情况呢?就是前面的数会被乘以概率多次,而后面的数乘以的概率却少了,实际上越往后期望所对应的概率应当是越高的,所以正序被如此推翻了。所以,我们得想个办法让后面的数被多乘,而前面的数尽可能保留,故用了逆推。

所以,正解应当是:dp[i]+=dp[i+j]/min(N-i, 6);当然,由于dp[i]定义是从后达到i时候的状态,故i点的金币是100%会拿到的,所以在输入的时候我就令他们取等了。

 

完整代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
#define pi 3.141592653589793
#define e 2.718281828459045
using namespace std;
typedef long long ll;
const int maxN=105;
int N;
double dp[maxN], a[maxN];
int main()
{
    int T;
    scanf("%d", &T);
    for(int Cas=1; Cas<=T; Cas++)
    {
        scanf("%d", &N);    memset(dp, 0, sizeof(dp));
        for(int i=1; i<=N; i++) { scanf("%lf", &a[i]); dp[i]=a[i]; }
        for(int i=N-1; i>=1; i--)
        {
            for(int j=1; j<=6; j++)
            {
                if(i+j<=N) dp[i]+=dp[i+j]/(double)min(N-i, 6);
            }
        }
        printf("Case %d: %.6lf\n", Cas, dp[1]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值