Discovering Gold (概率DP)

部分摘自:https://www.cnblogs.com/daydayupacm/p/5788115.html

原题目:

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

中文概要:

现在有n个格子,每个格子上都有一定的黄金值;还有一个色子(1-6)。起始位置站在格子1上面,若每次投掷色子得到数x,x+i<=n(i表示现处位置的格子编号),则可以到达(x+i)格子上;反之,再进行一次投掷。问:到达标号为n的格子上面,得到黄金的期望值是多少?

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<iostream>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=1005;
double dp[maxn];
int main()
{
	int t,n,num,cnt=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&num);
			dp[i]=num;
		}
		for(int i=n-1;i>=1;i--)
		{
			int x=min(6,n-i);//dp[i]最多只能从dp[i+7]的位置得来
            for(int j=1;j<=x;j++)
            {
            	dp[i]+=dp[i+j]*1.0/x;
			}
		}
		printf("Case %d: %.7lf\n",cnt++, dp[1]);

	}
	return 0;
}

思路:

期望:

一件不确定的事件有确定的所有结果,把第一种的结果值记为s1,它发生的概率记为p1,第二种结果值记为s2,它发生的概率为p2,... 第n种结果值记为sn,它发生的概率记为pn ... 那么期望值 Ei= s1*p1 + s2*p2 +... + sn*pn + ...

分析:

以第三个例子为例:

3

 

3 6 9

 

若我们现处在格子1,那么E1=3+6*1/2+9*1/2

(既然我们已经处在格子1了,1格子的黄金我们确定可以拿走了。剩下只有两种情况,要么到达格子2,要么到达格子3,所以两者概率分别为1/2。剩下的情况同理)

若我们现处在格子2,那么E2=6+9

若我们现处在格子3,那么E3=9

 

但是现在还有一个条件是色子只有6面(1-6),所以当n大于6时,比如

n=8,

E1=s1+s2*p2+s3*p3+s4*p4+s5*p5+s6*p6+s7*p7,

E2=s2+s3*p3+s4*p4+s5*p5+s6*p6+s7*p7+s8*p8。

其实最后意思就是只用考虑当前dp[i]的时候到dp[i+6]情况,至于后面的情况等跑到后面自然会分析到

 

 

另一种解释

1.   考的就是一个期望dp ,求期望一个很重要的就是逆求期望,为啥是逆求呢,如果正求是在前面期望的基础之上求期望。期望的期望只是一种可能性,并不符合概率要求。这个可以参考贝叶斯公式的定义,里面说的很清楚。关于求期望,要从已知推到未知,就这个题来说,已知只能是必定到达最后一个格子。所以要从已知走向位置就是逆着求的。
2.   dp[i]代表的是扔到第i个格子期望得到多少的金子。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 110;
double dp[maxn];
int num[maxn],t,n;
int main()
{
    scanf("%d",&t);
    int T = 1;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            dp[i] = num[i];
        }
        int count = 1;
        for(int i=n-1;i>=1;i--)
        {
            if(count > 6)//在后面没有六个格子可能性就没有六种
                count = 6;
            for(int j=1;j<=count;j++)
                dp[i] += (double)(dp[i+j]/count);
            count++;
        }
        printf("Case %d: ",T++);
        printf("%.7f\n",dp[1]);
    }
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

deebcjrb

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值