时间限制 : 1.000 sec 内存限制 : 32 MB
题目描述
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
输入
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
输出
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
样例输入 Copy
3 2
3 1
3 2
17 16
16 1
13 2
7 3
12 4
12 5
17 6
10 7
11 8
11 9
16 10
13 11
15 12
15 13
17 14
17 15
17 16
0 0
样例输出 Copy
3 1 2
17 6 14 15 12 4 5 13 2 11 8 9 16 1 10 7 3
把第二个样例输出按拓扑排序写一下,会发现每次出队列的时候会直接把这个队伍赢过的所有队伍入度–,若其中有队伍入度为0,再次这样操作。相当于一个dfs的搜索过程。
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 510;
int indegree[maxn] = { 0 }, n, m, num1, num2;
vector<int > g[maxn], topper;
queue<int > q;
void dfs(int x) {
for (int i = 0; i < g[x].size(); i++) {
int y = g[x][i];
indegree[y]--;
if (indegree[y] == 0) {
q.push(y);
dfs(y);
}
}
}
void maketop() {
for (int i = 1; i <= n; i++) {
if (indegree[i] == 0)
q.push(i);
}
while (!q.empty()) {
int u = q.front();
q.pop();
topper.push_back(u);
for (int i = 0; i < g[u].size(); i++) {
int v = g[u][i];
indegree[v]--;
if (indegree[v] == 0) {
q.push(v);
dfs(v);
}
}
}
}
int main() {
while (cin >> n >> m) {
if (n == 0 && m == 0)
break;
for(int i=0;i<maxn;i++)
g[i].clear();
fill(indegree, indegree + maxn, 0);
topper.clear();
for (int i = 0; i < m; i++) {
cin >> num1 >> num2;
g[num1].push_back(num2);
indegree[num2]++;
}
maketop();
for (int i = 0; i < topper.size(); i++) {
if (i != 0)
cout << " ";
cout << topper[i];
}
cout << endl;
}
return 0;
}