1074 Reversing Linked List (25分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

思路:静态链表存储,遍历一遍链表存入vector中。reverse函数反转vector中元素。

#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
struct ss {
	int pos, data, next;
}s[100010];

int main() {
	int begin, n, k, pos;
	cin >> begin >> n >> k;
	for (int i = 0; i < n; i++) {
		scanf("%d", &pos);
		s[pos].pos = pos;
		scanf("%d%d", &s[pos].data, &s[pos].next);
	}
	
	int p = begin;
	vector<ss > v;
	while (s[p].next != -1) {
		v.push_back(s[p]);
		p = s[p].next;
	}
	v.push_back(s[p]);

	for (int i = 0; i < v.size() / k; i++) {
    	reverse(v.begin() + i * k, v.begin() + (i + 1)*k);
	}
	for (int i = 0; i < v.size(); i++) {
		if (i != v.size() - 1)
			printf("%05d %d %05d\n", v[i].pos, v[i].data, v[i + 1].pos);
		else
			printf("%05d %d -1\n", v[i].pos, v[i].data);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值