歌德巴赫猜想

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: Every number greater than 2 can be written as the sum of three prime numbers. Goldbach was considering 1 as a primer number, a convention that is no longer followed. Later on, Euler re-expressed the conjecture as: Every even number greater than or equal to 4 can be expressed as the sum of two prime numbers.
For example: • 8 = 3 + 5. Both 3 and 5 are odd prime numbers. • 20 = 3 + 17 = 7 + 13. • 42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23. Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) Anyway,yourtaskisnowtoverifyGoldbach’sconjectureasexpressedbyEulerforallevennumbers less than a million. Input The input file will contain one or more test cases. Each test case consists of one even integer n with 6 ≤ n < 1000000. Input will be terminated by a value of 0 for n. Output For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b−a is maximized. If there is no such pair, print a line saying ‘Goldbach's conjecture is wrong.’ Sample Input 8 20 42 0 Sample Output 8 = 3 + 5 20 = 3 + 17 42 = 5 + 37

题目描述:给你一个偶数n,让你写成n=a+b,其中a,b为素数

打表即可,我的代码还可以优化,还可以建立素数表,然后直接从表中枚举

#include<cstring>
#include<iostream>
#include<cstdio>
using namespace std;
#pragma warning(disable:4996) //为了使用scanf
const int N = 1000000;
bool isprime[N + 5];
void prepare()
{
	memset(isprime, false, sizeof(isprime));
	for (int i = 2; i <= N; i++)
	{
		if (!isprime[i])
			for (int j = 2; i*j <= N; j++)
				isprime[i*j] = 1;
	}
}
int main()
{
	prepare();
	int n;
	while (cin >> n && n)
	{
		for (int i = 2; i <= n / 2; i++)         
			if (!isprime[i] && !isprime[n - i]) {
				printf("%d = %d + %d\n", n, i, n - i);
				break;
			}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值