hdu-1006

Tick and Tick

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22297    Accepted Submission(s): 5912


 

Problem Description

The three hands of the clock are rotating every second and meeting each other many times everyday. Finally, they get bored of this and each of them would like to stay away from the other two. A hand is happy if it is at least D degrees from any of the rest. You are to calculate how much time in a day that all the hands are happy.

 

 

Input

The input contains many test cases. Each of them has a single line with a real number D between 0 and 120, inclusively. The input is terminated with a D of -1.

 

 

Output

For each D, print in a single line the percentage of time in a day that all of the hands are happy, accurate up to 3 decimal places.

 

 

Sample Input

 

0 120 90 -1

 

 

Sample Output

 

100.000 0.000 6.251

 

 

Author

PAN, Minghao

 

 

Source

ZJCPC2004

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1007 1008 1010 1009 1011 

 

 

Statistic | Submit | Discuss | Note

心得:这个一开始想遍历时间,后来发现重复太多,参考了网上的文章才弄懂。

#include<bits/stdc++.h>
using namespace std;
int v[120];
int a,b,n,i;
int main(void)
{
    while(~scanf("%d%d%d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0) break;
        memset(v,0,sizeof(v));
        v[1]=1,v[2]=1;
        for(i=3;i<=49;i++)
        {
            v[i]=(v[i-1]*a+v[i-2]*b)%7;
        }
        if(n>49)
        {
            if(n%49==0) n=49;
            else n=n%49; 
        } 
        printf("%d\n",v[n]);
    }
    return 0;
}

参考文章:https://blog.csdn.net/a601025382s/article/details/37814777

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值