hdu 2680

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18677    Accepted Submission(s): 6053


 

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

 

 

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

 

 

Sample Input

 

5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1

 

 

Sample Output

 

1 -1

 

 

Author

dandelion

 

 

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  2112 2544 1217 2066 1142 

 

 

Statistic | Submit | Discuss | Note

 

心得:给出终点,但求起点的最小距离只需要把起点和终点发过来看就可以了,但是要注意输入的时候确定顺序,是有向图。

还要注意数组范围(再次被坑)。

#include<bits/stdc++.h>
using namespace std;

const int maxn=99999999;
int mp[1005][1005];
int vis[1005],le[1005];

int main(void)
{
	int n,m,i,j,a,b,x,st,ed,w;
	while(~scanf("%d%d%d",&n,&m,&ed))
	{
		memset(vis,0,sizeof(vis));
		memset(le,maxn,sizeof(le));
		for(i=1;i<=1003;i++)
		{
			for(j=1;j<=1003;j++)
			{
				if(i==j) mp[i][j]=0;
				else mp[i][j]=maxn;
			}
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&x);
			if(mp[b][a]>x) mp[b][a]=x;
		}
		for(i=1;i<=n;i++)
		{
			le[i]=mp[ed][i];
		}
		vis[ed]=1;
		for(j=1;j<=n;j++)
		{
			int k;
			int mi=maxn;
			for(i=1;i<=n;i++)
			{
				if(vis[i]==0&&le[i]<mi) //
				{
					mi=le[i];
					k=i;
				}
		    }
			vis[k]=1;
			for(i=1;i<=n;i++)
			{
				if(vis[i]==0&&le[k]+mp[k][i]<le[i])
				le[i]=le[k]+mp[k][i];
			}
		}
		int tp=maxn;
		scanf("%d",&w);
		while(w--)
		{
			scanf("%d",&st);
			if(le[st]<tp) tp=le[st];
		}
		if(tp==maxn) printf("-1\n");
		else printf("%d\n",tp);
	}
	return 0;
}

参考文章:https://blog.csdn.net/qq_31237061/article/details/50616658

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值