100000575 - 《算法笔记》3.1小节——问题 E: Shortest Distance (20)

题目描述:
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

输出:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入:

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出:

3
10
7

代码:

#include <iostream>
#include <cstring>
using namespace std;
const int N=1e5+5;
int a[N];
int main(){
	#ifdef ONLINE_JUDGE
	#else
		freopen("in.txt","r",stdin);
	#endif
	int n,count,sum=0,distance[N],headp,rearp,distval;//数组a[i]表示结点i到结点i+1的距离 
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
		sum+=a[i];
		distance[i+1]=sum;
	}
	scanf("%d",&count);
	for(int i=1;i<=count;i++){
		scanf("%d%d",&headp,&rearp);
		if(headp>rearp) swap(headp,rearp);
		distval=distance[rearp]-distance[headp];
		printf("%d\n",min(distval,sum-distval));
	}	 
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值