1016 Phone Bills(25)

💟这里是CS大白话专场,让枯燥的学习变得有趣!

💟没有对象不要怕,我们new一个出来,每天对ta说不尽情话!

💟好记性不如烂键盘,自己总结不如收藏别人!

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

🧡解析

💌要求输出某人在某个月内的有效通话记录,单次话费及总话费。

🍠难点:

1)按名字顺序和时间顺序对输入记录排序。

2)保存匹配的通话记录。

3)跨天的通话记录,且上线时间点晚于下线时间点。

4)无效记录不输出,即上下线在同一分钟。

🧡代码

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

struct record{
    string name;
    int month,day,hour,min;
    int time;
    string state;
}rec[1000];

bool cmp(record rec1,record rec2){
    // 名字升序,时间升序
    return rec1.name.compare(rec2.name)==0 ? 
        rec1.time<rec2.time : rec1.name.compare(rec2.name)<0;
}

int main(){
    int cost[24];
    int alldayCost=0;
    for(int i=0;i<24;i++){
        cin >> cost[i];
        alldayCost += cost[i]*60;
    }
    int N = 0;
    cin >> N;
    for(int i=0;i<N;i++){
        cin >> rec[i].name;
        scanf(" %d:%d:%d:%d ",&rec[i].month,&rec[i].day,&rec[i].hour,&rec[i].min);
        cin >> rec[i].state;
        rec[i].time = rec[i].day*24*60 + rec[i].hour*60 + rec[i].min;
    }
    sort(rec,rec+N,cmp);
    vector<record> customer; //保存匹配后的记录
    for(int i=0;i<N-1;i++){
        if(rec[i].name.compare(rec[i+1].name)==0)
            if(!rec[i].state.compare("on-line") && !rec[i+1].state.compare("off-line")){
                customer.push_back(rec[i]);
                customer.push_back(rec[i+1]);
                i++;
            }
    }
    
    //if(customer.size()==0) return 0;

    string last_name;
    float totalAmount = 0;
    for(unsigned int i=0;i<customer.size();i+=2){
        // 先算一次记录的钱
        float pay=0;
        float adPay=0;
        pay += (customer[i+1].day-customer[i].day)*alldayCost;
        if((customer[i].hour<customer[i+1].hour)||(customer[i].hour==customer[i+1].hour&&customer[i].min<customer[i+1].min)){
            for(int j=customer[i].hour;j<customer[i+1].hour;j++){
                adPay += cost[j]*60;
            }
            adPay = adPay+customer[i+1].min*cost[customer[i+1].hour]-customer[i].min*cost[customer[i].hour];
            pay = (pay + adPay)/100;
        }
        // 如果不在同一天,上线时间点在下线时间点之后
        else{
            for(int j=customer[i+1].hour;j<customer[i].hour;j++){
                adPay += cost[j]*60;
            }
            adPay = adPay+customer[i].min*cost[customer[i].hour]-customer[i+1].min*cost[customer[i+1].hour];
            pay = (pay - adPay)/100;
        }
        
        // 有消费才输出
        if(pay){
            // 如果不是同一个人,则输出上一个人的总消费及新的名字和日期
            if(customer[i].name.compare(last_name)){
                if(totalAmount) printf("Total amount: $%.2f\n",totalAmount);
                totalAmount = 0;
                printf("%s ",customer[i].name.c_str());
                printf("%02d\n",customer[i].month); 
                last_name = customer[i].name;
            }
            // 输出本次消费记录
            printf("%02d:%02d:%02d ",customer[i].day,customer[i].hour,customer[i].min);
            printf("%02d:%02d:%02d ",customer[i+1].day,customer[i+1].hour,customer[i+1].min);
            printf("%d ",customer[i+1].time-customer[i].time);
            printf("$%.2f\n",pay);
            totalAmount += pay;
        }
    }
    if(totalAmount) printf("Total amount: $%.2f\n",totalAmount);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值