[kuangbin带你飞]专题一 简单搜索 L - Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

dfs()的入门题,应该是专题一,中最水的一题了。

题目大意:给你一张地图,@代表油田*代表没有油田,当@四周(八个方向)有@则属于一片的油田,要我们计算出地图中有几片的油田。

解题思路:反正题目给的地图也很小,100*100,直接暴力寻找@,找到就进行深搜,每走一步@就把它改为*,在开个ans来记录深搜了,几次就是有几片油田。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<queue>
#include<string>
#include<string.h>
#include<set>
#include<math.h>
using namespace std;
int n,m;
char map[105][105];
int d[8][2]={-1,0,1,0,0,1,0,-1,1,1,-1,-1,1,-1,-1,1};
int flag;
int chark(int a,int b)///判断有没有越界
{
    return (a>=0 && a<n && b>=0 && b<m);
}
int dfs(int x,int y)
{
    if(map[x][y] == '*')
    {
        return false;
    }
    flag = 1;
    map[x][y] = '*';///每但找到一个@就改为*;
    for(int i=0; i<8; i++)
    {
        if(chark(x+d[i][0],y+d[i][1]))
        {
            dfs(x+d[i][0],y+d[i][1]);
        }
    }
    return flag;
}
int main()
{
    while(~scanf("%d%d",&n,&m) && m+n)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s",map[i]);
        }
        int ans =0;
        for(int i=0; i<n; i++) ///开始找@为入口
        {
            for(int j=0; j<m; j++)
            {
                flag = 0;
                if(dfs(i,j))
                {
                    ans ++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值