Making the Grade(简单dp利用离散化和维护最大值优化时间复杂度)

问题 F: Making the Grade

时间限制: 1 Sec  内存限制: 128 MB
提交: 9  解决: 6
[提交] [状态] [讨论版] [命题人:admin]

题目描述

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|A1 - B1| + |A2 - B2| + ... + |AN - BN |
Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

 

输入

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

 

输出

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

 

样例输入

7
1
3
2
4
5
3
9

 

样例输出

3

题目 给一个n 输入n个数的数组w[i];

 

可以简单写出 dp[i][j] = abs(j-w[i])+min(dp[i-1][k])  (k<=j)  j为序列最大值

参考大佬博客:https://blog.csdn.net/hellohelloc/article/details/52060390

我的ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long LL;
int n;
LL dp[2005][2005],a[2005],b[2005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            b[i] = a[i];
        }
        sort(b+1,b+n+1);
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            LL maxn = dp[i-1][1];
            for(int j=1; j<=n; j++)
            {
                maxn = min(maxn,dp[i-1][j]);
                dp[i][j] = abs(b[j]-a[i])+maxn;
            }
        }
        LL ans = dp[n][1];
        for(int i=2; i<=n; i++)
        {
            ans = min(ans,dp[n][i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值