Making the Grade【dp+离散化】

Making the Grade
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8774 Accepted: 4104

Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A B 1| + | A B 2| + ... + | AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

Source


思路:

本题的数据有问题,只需要考虑非严格递增的情况。下面给出了个人认为比较正确的代码。

由于修整路面时,最优的策略肯定是左对齐或右对齐。所以不会出现给出的数据之外的数据。我们就可以离散化。

定义dp[i][j]:将第i个位置修整为j时的最小花费。

非严格递增转移方程:dp[i][j]=abs(b[j]-a[i])+min(dp[i-1][p]),1<=p<=j;

这样会超时。我们可以维护一个最小值。m=min(m,dp[i-1][j])。每次加上这个最小值即可。

非严格递减与之类似。

非严格递减转移方程:dp[i][j]=abs(b[j]-a[i])+min(dp[i-1][p]),j<=p<=n;


代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<map>
#include<stdlib.h>
using namespace std;
const long long inf = (long long)1<<62;
int n;
long long a[2005],b[2005];
long long dp[2005][2005];
long long aabs(long long x)
{
    if(x<0) return -x;
    return x;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+n+1);
        memset(dp,0,sizeof dp);
        long long m=inf;
        for(int i=1;i<=n;i++)//非严格递增
        {
            m=inf;
            for(int j=1;j<=n;j++)
            {
                m=min(m,dp[i-1][j]);
                dp[i][j]=aabs(b[j]-a[i])+m;
            }
        }
        long long ans=inf;
        for(int i=1;i<=n;i++)
            if(dp[n][i]<ans)
                ans=dp[n][i];
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++)//非严格递减
        {
            m=inf;
            for(int j=n;j>=1;j--)
            {
                m=min(m,dp[i-1][j]);
                dp[i][j]=aabs(b[j]-a[i])+m;
            }
        }
        for(int i=1;i<=n;i++)
            if(dp[n][i]<ans)
                ans=dp[n][i];
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值