Cheapest Palindrome(dp 构成回文串的最小花费)

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题意:求一个含有 n 种小写字母且长度为 m 的字符串,给出获得每种字符的价格,以及删除每种字符的价格。求如果把这个字符串变成一个回文串的最小花费。

思路:因为是变成回文串,因为添加或者删除一个字符的效果是等效的,因此我们可以求得对每种字符进行操作的最小花费。然后可以从第二个字符开始,尝试构造出任意长度的字符串的最小花费。dp[i][j]表示从[i,j]之间要构成回文串的最小费用。

状态转移方程为:

if(str[j]==str[k]) //这个区间的两端相等,因此两端对总费用没影响,因此它等于两段点相互靠近一步的值
                    dp[j][k]=dp[j+1][k-1];
else{              
   dp[j][k]=min(dp[j][k],dp[j+1][k]+ans[str[j]-'a']); //如果把左端的进行处理,取处理完左端点的花费
   dp[j][k]=min(dp[j][k],dp[j][k-1]+ans[str[k]-'a']);//相当于比较一下是对左端点处理花费少还是右端点花费少
}

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
char str[2010];             //ans[]存这个字符的费用
int ans[30],dp[2010][2010];//dp[i][j]表示从[i,j]之间要构成回文串的最小费用
int main()
{
    int n,m;
    while(~scanf("%d%d",&m,&n))
    {
        char c;
        int x,y;
        scanf("%s",str);
        memset(ans,0,sizeof(ans));
        for(int i=0; i<m; i++)
        {
            getchar();
            scanf("%c %d%d",&c,&x,&y);
            ans[c-'a']=min(x,y);//要构造回文串,只是对这个字符进行操作,不管是删除还是添加都无所谓,因此只取最小的费用
        }
        for(int i=1; i<n; i++) //  从第二个字符开始
        {
            for(int j=0,k=i; k<n; j++,k++) //以相同的宽度i ,从[0,i]依次向右取区间,算最小值
            {
                dp[j][k]=inf;      //因为每个区间只会出现一次,因此要初始化为inf
                if(str[j]==str[k]) //这个区间的两端相等,因此两端对总费用没影响,因此它等于两段点相互靠近一步的值
                    dp[j][k]=dp[j+1][k-1];
                else
                {
                    //如果把左端的进行处理,取处理完左端点的花费
                    dp[j][k]=min(dp[j][k],dp[j+1][k]+ans[str[j]-'a']);
                    dp[j][k]=min(dp[j][k],dp[j][k-1]+ans[str[k]-'a']);//相当于比较一下是对左端点处理花费少还是右端点花费少
                }
            }
        }
        printf("%d\n",dp[0][n-1]);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值