Elune's Arrow(几何,解二元一次方程)

Priestess of the Moon (PotM) is a very interesting hero in the game Defense of the Ancients (DotA). Here is the official description of PotM:

  • "A matriarch and high priestess of Elune's blessed order, Mirana Nightshade serves as a light in darkness for the front line of the Sentinel ranks, raining arrows and falling stars alike upon the shambling undead masses of the Undead Scourge, while her very presence is said to be so holy that it melts away the fatigue of nearby allies, giving them greater haste on the battlefield. In times of need however, she can fade herself and others around her into the safety of invisibility, making her a potent supporter matched by few."

She has a very powerful skill named Elune's Arrow. When she uses this ability, she fires an arrow to a location with deadly precision, dealing large damage and stunning the first unit it strikes. A powerful skill, but hard to manage, because the enemy never stands still waiting for your arrow, and you can't change the angle after you fires the arrow. For the sake of simplicity, you can assume that the enemy's body area is a circle with radius r0, the effective range of your arrow is also a circle with radius r1, and the enemy always runs in a straight line. Now, PotM is standing at (x1y1), while the enemy's position is (x0y0). The enemy's speed in both x and y directions can be represent by a vector (dxdy). So, after t minutes, the enemy's position will be (x0+dx*ty0+dy*t). The speed of PotM's arrow is v. If the effective range of the arrow touches the enemy's body area, it will be considered a strike, just like the collision of two circles. Now PotM wants to strike the enemy as soon as possible, could you help her to determine the time which the arrow takes to strike the enemy?

 

Input

 

The first line of the input contains a single number T (T <= 100), indicating the number of cases.

Each case consists of 5 lines, and each line contains the following decimal numbers:

  • x0y0 (the enemy's initial position)
  • x1y1 (PotM's initial position)
  • dxdy (speed vector of the enemy)
  • r0r1 (radii of the circles of the enemy's body and the effective range of the arrow)
  • v, (positive speed of the arrow)

There is a blank line between the cases. 
Note: the initial distance between PotM and the enemy will be larger than r0r1.

 

 

Output

 

For each case, output the least time (in minutes) PotM needs to strike the enemy(accurate up to 4 decimal places). If PotM cannot strike the enemy, just output "Impossible" in one line.

 

Sample Input

 

2
0.0 0.0
4.0 0.0
1.0 0.0
1.0 1.0
2.0

0.0 0.0
300.0 400.0
-3.0 -4.0
1.0 1.0
5.0

 

Sample Output

 

0.6667
Impossible

题意:一个敌人在(x1,y1)点,它的大小为半径r0,而且它还有一个移动方向:向量(dx,dy)。一个人站在(x0,y0)处,拿了一把射程为 r1 的枪。并且他可以超任意方向以v的速度移动,问这个人想要消灭敌人最少需要多长时间,不能的话输出 Impossible。

思路:如下图:

代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        double x0,y0,x1,y1,r0,r1,dx,dy,v;
        cin>>x0>>y0>>x1>>y1>>dx>>dy>>r0>>r1>>v;
        double a=v*v-dx*dx-dy*dy;
        double b=2*(v*(r1+r0)-(x0-x1)*dx-(y0-y1)*dy);
        double c=(r0+r1)*(r0+r1)-(x1-x0)*(x1-x0)-(y1-y0)*(y1-y0);
        double d=b*b-4*a*c;
        if(a==0) //一元一次方程
        {
            if(b==0) printf("Impossible\n");
            else
            {
                if(-c/b>0) printf("%.4f\n", -c/b);
                else printf("Impossible\n");
            }
        }
        else if(d<0)printf("Impossible\n");
        else
        {
            d=sqrt(d+0.0);
            double t1=(d-b)/(2.0*a);
            double t2=(-b-d)/(2.0*a);
            if(t1<0&&t2<0||a==0)printf("Impossible\n");
            else if(t1<0||t2<0)printf("%.4lf\n",max(t1,t2));
            else printf("%.4lf\n",min(t1,t2));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值