Mathematically Hard(小于n且与n互质的数的个数==欧拉函数,欧拉表)

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler's totient function  applied to a positive integer n is defined to be the number of positive integers less than or equal to n that are relatively prime to n is read "phi of n."

Given the general prime factorization of , one can compute  using the formula

题意:先说值吧,函数是求n之前的数与n互质的数的个数,术语:欧拉值。欧拉公式上图也给出来了。那么这道题求的是区间[a,b] 的欧拉值的平方之和。

知识要点:怎样求欧拉值呢?赶紧去偷一个板子:

ph[1] = 1 ;//结合欧式筛法,可以求出 n 以内每一个数的欧拉函数值
scanf("%d", &n );
for(int  i = 2 ; i <= n ; ++ i )
{
    if(!vis[i])
    {
        cnt ++ ;
        pr[cnt] = i ;
        ph[i] = i - 1 ;
    }
    for(int j = 1 ; j <= cnt && i * pr[j] <= n ; ++ j )
    {
        vis[ i * pr[j] ] = 1 ;
        if( i % pr[j] == 0 )
        {
            ph[ pr[j] * i ] = ph[i] * pr[j] ;
            break;
        }
        else
            ph [ pr[j] * i] = ph[i] * (pr[j] - 1 );
    }
}

这道题数据500w,肯定是要打表的,那么下面就找一个大佬的简洁的欧拉表算法。

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 5000010
#define ull unsigned long long
using namespace std;
ull Sum[N];
void init()
{
    for(int i = 0; i <N; i++)
        Sum[i] = i;
    for(int i = 2; i <N; i++) //打欧拉函数的表
        if(Sum[i] == i)
        {
            for(int j = i; j <N; j+=i)
                Sum[j] = Sum[j]/i*(i-1);
        }
    for(int i=1; i<N; i++)
        Sum[i]=Sum[i-1]+Sum[i]*Sum[i];
}
int main()
{
    init();
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",cas++,Sum[b]-Sum[a-1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值