PAT 1061 Dating

题目
1061 Dating (20 分)
Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04

题目意思
有四个字符串,根据前面两个字符串确定星期几和几点,后面两个确定分钟。
第一个前两个字符串相同并且在(A-G)范围内的字符,确定星期几,第二个前两个字符串相同并且在(0-9)或者(A-N)范围内的字符确定时钟。第一个后两个字符串相同的字符的位置就是分钟。

思路
根据题目意思模拟。有个坑就是时钟和分钟都一定是两位数买不够的补零(即%02d)

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>

using namespace std;

int hx(char c)
{
    if(c>='A' && c<='Z')
        return 1;
    else if(c>='a' && c<='z')
        return 1;
    else
        return 0;
}

int main()
{
    char mz[10][13]={"0","MON","TUE","WED","THU","FRI","SAT","SUN"};
    char a[63],b[63],c[63],d[63];
    scanf("%s%s%s%s",a,b,c,d);
    int flag=0,x;
    for(int i=0;i<strlen(a)&&i<strlen(b);i++)
    {
        if(a[i]==b[i]&&!flag&& a[i]>='A' && a[i]<='G')
        {
            x = a[i]-'A'+1;
            printf("%s ",mz[x]);
            flag=1;
        }
        else if(a[i]==b[i] &&flag==1)
        {
            if(a[i]>='0'&&a[i]<='9')
            {
                printf("%02d:",a[i]-'0');
                break;
            }

            else if(a[i]>='A' && a[i]<='N')
            {
                x = a[i]-'A'+10;
                printf("%d:",x);
                break;
            }
            continue;
        }
        else
            continue;
    }
    for(int i=0;i<strlen(c)&&i<strlen(d);i++)
    {
        if(c[i]==d[i] && hx(c[i]))
        {
            printf("%02d\n",i);
            break;
        }
    }
   return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值