PAT 1061 Dating(20分)未完成

原题链接:PAT 1061 Dating(20分)

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

题目大意:

给了你四行字符串,要求从里面解出日期信息:

  • 前两个字符串中第一个出现的相同大写字母(A-G)代表星期
  • 前两个字符串中第二个出现的相同数字(0-9)或者大写字母(A-N)代表小时,注意要补0
  • 后两个字符串中第一个出现相同字母(不管大小写)的位置代表分钟,注意要补0

最后按格式输出即可

方法一:字符串

C++代码:

// pat 1061 测试点2和5还是没过 
#include <iostream>
#include <cstring>
using namespace std;

string s[5];
string week[7] = {"MON", "TUR", "WED", "THU", "FRI", "SAT", "SUN"};

int main(){
	for(int i = 1; i <= 4; i++)
		getline(cin, s[i]);

	// 前两个字符判断星期、小时数 
	bool flag = 0;	// flag为0时表示判断星期 
	for(int i = 0; i < min(s[1].size(), s[2].size()); i++ ){
		// 判断星期 
		if(s[1][i] == s[2][i] && s[1][i] >= 'A' && s[1][i] <= 'G' && flag == 0){
			cout << week[s[1][i] - 'A'] << " "; 
			flag = 1; 
			continue;
		} 
		
		// 判断小时
		if(s[1][i] == s[2][i] && s[1][i] >= '0' && s[1][i] <= '9' && flag == 1){
			printf("%02d:", s[1][i] - '0');
			break;
		}
		if(s[1][i] == s[2][i] && s[1][i] >= 'A' && s[1][i] <= 'N' && flag == 1){ 
			cout << s[1][i] - 'A' + 10 << ":";
			break;
		}

	}
	
	// 后两个字符判断分钟数 
	for(int i = 0; i < min(s[3].size(), s[4].size()); i++ ){
		// 这里不管大小写只要相同即可 
		if(s[3][i] == s[4][i] && ((s[3][i] > 'a' && s[3][i] < 'z') || (s[3][i] > 'A' && s[3][i] < 'Z'))){
			printf("%02d\n", i);
			break; 
		} 
	}
	
	
	return 0;
} 

复杂度分析:

  • 时间复杂度:O(n),最坏情况下会遍历每个字符
  • 空间复杂度:O(n),存储题目给出的四个字符串

测试点分析:

  • 测试点3:注意星期三是WED,不要打错
  • 16
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值