2136 Largest prime factor
Problem Description Everybody knows any number can be combined by the prime number. Now, your task is telling me what position of the largest prime factor.The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc. Specially, LPF(1) = 0.
Input Each line will contain one integer n(0 < n < 1000000).
Output Output the LPF(n).
Sample Input
1 2 3 4 5
Sample Output
0 1 2 1 3
TLE...
#include<stdio.h>
#include<math.h>
int main()
{
int prime[80000];
int j,index=1;
for (j=2; j<1000000; j++) {
if(isprime(j)==1) {
prime[index] = j;
index++;
}
}
int input;
while(scanf("%d",&input)!=EOF) {
if(input==1) {
printf("0n");
}
else{
int factor;
for(j=1; j<=input; j++){
if((input%j==0)&&(isprime(j)==1)){
factor = j;
}
}
printf("factor is %dn",factor);
for(index=1; index<80000; index++){
if(prime[index]==factor){
printf("%dn",index);
break;
}
}
}
}
return 0;
}
int isprime(int num){
int i;
for(i=2; i<=sqrt(num); i++){
if(num%i==0){
return 0;
}
}
return 1;
}
别人家的思想:
参考来源: https://blog.csdn.net/wyf12138/article/details/51694295
#include <stdio.h>
#include <math.h>
#define MAX 1000001
int lpf[MAX];
int main()
{
int n,i,j,postion=0;
//postion表示某个素数在素数表中的位置
/*先运用素数筛法的原理计算所有1到MAX中的lpf*/
lpf[1]=0;
//lpf(1)=0
for(i=2;i<MAX;i++) //从素数2开始依次判别素数
{
if(lpf[i]==0) //如果i还未被未被小于自身的任何素数整除,则确定i也是素数
{
postion++;
/*postion的值更新后,表示素数i在素数表中是第postion个*/
for(j=i;j<MAX;j+=i)
lpf[j]=postion;
//所有是i的倍数的整数,lpf的值暂时为postion
/*由于筛选出的素数从小到大,lpf[a](a为任一整数)一定
会被a的最大的素因数的postion所覆盖,也就是最终会有
数组元素lpf[a]=函数值lpf(a)*/
}
}
while(scanf("%d",&n)!=EOF)
{
printf("%d\n",lpf[n]);
}
return 0;
}