Maximum Product

Given a sequence of integers S = {S1, S2, … , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.

hint
- 第一个是我看了大佬的代码乱敲的。
- 第二个是大佬的代码
- 个人感觉第二个代码是有点问题的,max最初被定义为0,只有mul>max,max才会等于mul,所以按理来说不应该会出现max<0这种情况,最多max=0;但两种情况都能A,所以仅供参考。

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int n,i,j,a[20],cn;
    long long int max;
    cn=0;
    while(scanf("%d",&n)!=EOF)
    {
        cn++;
        max=0;
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(i=0; i<n; i++)
        {
            long long int mul;
            mul=1;
            for(j=i; j<n; j++)
            {
                mul=mul*a[j];
                if(mul>max)
                    max=mul;
            }
        }
        if(max>0)
            printf("Case #%d: The maximum product is %lld.\n",cn,max);
        else  printf("Case #%d: The maximum product is 0.\n",cn);
        printf("\n");
    }
    return 0;
}
///连续子序列有两个要素:起点和终点,因此只需枚举起点和终点即可。由于每个元素的绝对值不超过10且不超过18个元素,
///最大可能的乘积不会超过10的18次方,可以用long long来存;
#include<stdio.h>
int main()
{
    int n,i,j,a[20],f=1;
    long long int ans,max1;
    while(~scanf("%d",&n))
    {
        max1=0;
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)///枚举起点;
        {
            ans=1;
            for(j=i;j<n;j++)///枚举终点;
            {
                ans*=a[j];
                if(ans>max1)///找到较大的乘积就赋值给max1;
                    max1=ans;
            }
        }
        printf("Case #%d: The maximum product is ",f++);
        if(max1<0)printf("0.\n");
        else
            printf("%lld.\n\n",max1);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值