【题解】hdu2689 Sort it 树状数组

题目链接

Description

You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.

Output

For each case, output the minimum times need to sort it in ascending order on a single line.

Sample Input

3
1 2 3
4
4 3 2 1

Sample Output

0
6


树状数组求逆序对裸题……5分钟以内写完,还算比较熟

#include<cstdio>
#include<cstring>
const int N=1e3+10;
int n,sum[N<<1];
void add(int x){for(;x<=n;x+=x&-x)sum[x]++;}
int query(int x)
{
    int ret=0;
    for(;x;x-=x&-x)ret+=sum[x];
    return ret;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n))
    {
        int ans=0;
        memset(sum,0,sizeof(sum));
        for(int i=1;i<=n;i++)
        {
            int x;
            scanf("%d",&x);
            ans+=query(n)-query(x-1);
            add(x);
        }
        printf("%d\n",ans);
    }
    return 0;
}

总结

巨水

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值