poj2392

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12123 Accepted: 5769

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48


题意:有n种石头,每个石头的高度hi,允许用的最高高度为ai,数量为ci,求能组合的最高高度。


思路:先给这些石头排个序,最高高度小的在前面,这样才能使得高度最大,然后再按多重背包来做,这样就可以了。


代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
    int h,a,c;
}a[405];
bool cmp(node a,node b)
{
    return a.a<b.a;
}
int dp[40005];
int main()
{
    int k;
    while(cin>>k)
    {
        int i,j,z;
        for(i=0;i<k;i++)
        {
            scanf("%d %d %d",&a[i].h,&a[i].a,&a[i].c);
        }
        sort(a,a+k,cmp);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(i=0;i<k;i++)
        {
            for(j=0;j<a[i].c;j++)
            {
                for(z=a[i].a;z>=a[i].h;z--)
                {
                    dp[z]|=dp[z-a[i].h];
                }
            }
        }
        for(i=a[k-1].a;i>=0;i--)
        {
            if(dp[i])
            {
                cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值