HDU2056-Rectangles

HDU2056-Rectangles

题目:
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25

#include<bits/stdc++.h>
using namespace std;

double a[5],b[5];
int main()
{
    double x1,x2,y1,y2,x3,y3,x4,y4;
    while(~scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&a[0],&b[0],&a[1],&b[1],&a[2],&b[2],&a[3],&b[3]))
    {
        x1 = max(a[0],a[1]);
        y1 = max(b[0],b[1]);
        x2 = min(a[0],a[1]);
        y2 = min(b[0],b[1]);
        x3 = max(a[2],a[3]);
        y3 = max(b[2],b[3]);
        x4 = min(a[2],a[3]);
        y4 = min(b[2],b[3]);
        if(x1 <= x4 || x2 >= x3 || y1 <= y4 || y2 >= y3) cout << "0.00" << endl;
        else
        {
            sort(a,a + 4);
            sort(b,b + 4);
            printf("%.2lf\n",(a[2] - a[1]) * (b[2] - b[1]));
        }
    }
    return 0;
}

这道题要分为两种情况去考虑,第一种就是两个矩形相交的情况,第二种就是两个矩形不相交的情况。

先来讨论第一种情况,通过画图分析可以得知相交部分的面积就是横坐标的较大值减去横坐标的较小值乘以纵坐标的较大值减去纵坐标的较小值.(在这里我们可以先对横纵坐标进行从小到大排序)。

再来讨论矩形不相交的情况,首先计算出第一个矩形和第二个矩形最小和最大的横坐标和纵坐标,如果矩形1的最小横坐标>=矩形2的最大横坐标或者矩形1的最大横坐标<=矩形2的最小横坐标(纵坐标也是一个道理),那么此时矩形不相交。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值