POJ - 3311 Hie with the Pie

题目:
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.
Input
Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.
Output
For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.
Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8
代码如下:

#include<iostream>
using namespace std;
int n,a[15][15],dp[3000][15];
int dis[15][15];
void floyd()
{
	for(int k = 0;k <= n;k++)
		for(int i = 0;i <= n;i++)
			for(int j = 0;j <= n;j++)
				dis[i][j] = min(dis[i][j],dis[i][k] + dis[k][j]);
}
int main()
{
	while(~scanf("%d",&n) && n != 0){
		for(int i = 0;i <= n;i++) for(int j = 0;j <= n;j++) cin >> dis[i][j];
		floyd();
		for(int s = 0;s < (1 << n);s++){
			for(int i = 1;i <= n;i++){	//从第1个点到第n个点尝试 
				if(s & (1 << (i - 1))){	//状态s中已经走到i点 
					if(s == (1 << (i - 1))) dp[s][i] = dis[0][i];//从0点出发走到i点,dp的边界
					else{
						dp[s][i] = 0x3f3f3f3f;
						for(int j = 1;j <= n;j++){
							if(i != j && s & (1 << (j - 1))) //j不能等于i,并且状态s中要走到j点 
								dp[s][i] = min(dp[s][i],dp[s ^ (1 << (i - 1))][j] + dis[j][i]);//松弛操作 
						}
					} 
				} 
			}
		} 
		int ans = 0x3f3f3f3f;
		for(int i = 1;i <= n;i++) ans = min(ans,dp[((1 << n) - 1)][i] + dis[i][0]);
		cout << ans << endl; 
	}
	return 0;
}

题意:
从0点出发经过每个点再回到0点的最短距离。
思路:
如果暴力枚举会发现会有很多重叠的子问题,所以这里采用状压dp来做。因为要知道点和点之间的最短距离,所以这里先要用floyd算法计算出点与点之间的最短路径。然后进行dp,dp[s][i]代表状态为s时正好走到i点所走的路径。具体过程代码旁有注释。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值