【个人代码及思路】PAT甲级:PAT甲级:1059 Prime Factors (25分)

PAT (Advanced Level) Practice

1059 Prime Factors (25分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p1kp2k2×⋯×pmk**m.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p1^k1*p2^k2**p**m^k**m, where p**i’s are prime factors of N in increasing order, and the exponent k**i is the number of p**i – hence when there is only one p**i, k**i is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

个人代码:

#include <cstdio>
#include <cmath>

const int MAXN = 100010;
int prime[MAXN], pNum = 0; //素数表,素数个数
bool isPrime[MAXN] = {0}; //0代表下标对应的数是素数

struct factor {
    int p, k;
} fac[10];

void pTable (int sqr) {  //素数表
    for (int i = 2; i < MAXN; i++) { //埃氏筛法
        if (prime[pNum] > sqr) break;
        if (!(isPrime[i])) { //如果是素数,加入素数表并开始表晒
            prime[pNum++] = i;
            for (int j = i; j < MAXN; j += i) {
                isPrime[j] = true;
            }
        }
    }
}

void findPrime (int n) { //找出所有质因数
    int cnt = 0; //不同质因数的个数
    for (int i = 0; i < pNum; i++) {
        if (n % prime[i] == 0) { //若该素数为因子,则指数加一
            fac[cnt].p = prime[i];
            fac[cnt].k = 0;
            while (n % prime[i] == 0) {
               (fac[cnt].k)++; 
               n /= prime[i];
            }
            cnt++;
        }
        if (n == 1) break; //已经找到全部质因子
    }
    if (n != 1) { //还存在一个大于根号n的质因子
        fac[cnt].k = n;
        fac[cnt].p = 1;
    }
    for(int i = 0; i < cnt; i++) {
        printf("%d", fac[i].p);
        if (fac[i].k != 1) {
            printf("%s%d", "^", fac[i].k);
        }
        if(i == cnt-1) break;
        printf("*");
    }
}

int main () {
    int n;
    scanf("%d", &n);
    int sqrtn = (int)sqrt(n * 1.0);
    //调用素数表
    if (n == 1) {
        printf("1=1");
    } else {
        pTable(sqrtn);
        printf("%d=", n);
        //2到根号n判断找出其所有质因数
        findPrime(n);
    }
    return 0;
}

思路提示:

n最多有一个大于根号n的质因数

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值