OJ(1988):Cube Stacking

总时间限制: 

2000ms

 

单个测试点时间限制: 

1000ms

 

内存限制: 

65536kB

描述

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

输入

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

输出

Print the output from each of the count operations in the same order as the input file.

样例输入

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

样例输出

1
0
2

来源

USACO 2004 U S Open

除了parent数组,还要开设sum数组:记录每堆一共有多少方块。若parent[a] = a, 则sum[a]表示a所在的堆的方块数目。
under数组,under[i]表示第i个方块下面有多少个方块。under数组在 堆合并和 路径压缩的时候都要更新。

#include<iostream>
#include<cstdio>
#define maxn  31000

using namespace std;

int under[maxn];
int sum[maxn];
int f[maxn];

int getf(int a){
    if(f[a]==a)
        return a;
    int t = getf(f[a]); //保证到根节点的所有under值都更新(回溯方向考虑)
    under[a] += under[f[a]];
    f[a]=t;
    return f[a];
}
void Merge(int x,int y){
    int t1 = getf(x);
    int t2 = getf(y);
    f[t1] = t2;
    under[t1] = sum[t2];
    sum[t2] += sum[t1];
}
int main()
{
    int n;
    for(int i = 0;i < maxn;i++){
        under[i] = 0;
        f[i] = i;
        sum[i] = 1;
    }
    scanf("%d",&n);
    for(int i = 1;i <= n;i++){
        char s;
        int x,y;
        getchar();
        scanf("%c",&s);
        if(s == 'M'){
            scanf("%d%d",&x,&y);
            Merge(x,y);
        }
        else {
            scanf("%d",&x);
            getf(x);
            printf("%d\n",under[x]);
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值