Bulbs

题目描述

Greg has an m × n grid of Sweet Lightbulbs of Pure Coolness he would like to turn on. Initially, some of the bulbs are on and some are off. Greg can toggle some bulbs by shooting his laser at them. When he shoots his laser at a bulb, it toggles that bulb between on and off. But, it also toggles every bulb directly below it,and every bulb directly to the left of it. What is the smallest number of times that Greg needs to shoot his laser to turn all the bulbs on?

 

输入

The first line of input contains a single integer T (1 ≤ T ≤ 10), the number of test cases. Each test case starts with a line containing two space-separated integers m and n (1 ≤ m, n ≤ 400). The next m lines each consist of a string of length n of 1s and 0s. A 1 indicates a bulb which is on, and a 0 represents a bulb which is off.

 

输出

For each test case, output a single line containing the minimum number of times Greg has to shoot his laser to turn on all the bulbs.

 

样例输入

复制样例数据

2
3 4
0000
1110
1110
2 2
10
00

样例输出

1
2

 

提示

In the first test case, shooting a laser at the top right bulb turns on all the bulbs which are off, and does not
toggle any bulbs which are on.
In the second test case, shooting the top left and top right bulbs will do the job.

题意: 输入一个图,通过翻转每个点来使全部的点都变成1,当翻转一个点时,这个点的左边所有的点和下面所有的点都会变(0变1,1变成0)

题解:为了次数最小,要保证不重复操作一个点(操作偶数次和原来结果一样),因为每个点会影响左边的和下面的,所以从右上角开始是最快的。所以只要从右上角往左开始操作遇到0就翻转是最快的。

#include<iostream>
#include<cstdio>

const int maxn = 400+2;
int G[maxn][maxn];

using namespace std;

int main()
{
    int t,step;
    cin>>t;
    while(t--){
        step = 0;
        int n,m;
        cin>>n>>m;
        for(int i = 0;i<n;i++){
            for(int j = 0;j<m;j++){
                char c;
                cin>>c;
                G[i][j] = c-'0';
            }
        }
        for(int i = 0;i < n;i++){
            for(int j = m-1;j >= 0;j--){
                if(G[i][j] == 0){
                   step++;
                   for(int k = i;k<n;k++){ //改当前一列
                        if(G[k][j] == 0)
                            G[k][j] = 1;
                        else
                            G[k][j] = 0;
                   }
                   for(int k = j;k>=0;k--){ //改当前一行
                        if(G[i][k] == 0)
                            G[i][k] = 1;
                        else
                            G[i][k] = 0;
                   }
                }
            }
        }
        cout<<step<<endl;
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值