Sequence in the Pocket

Time Limit: 1 Second      Memory Limit: 65536 KB


DreamGrid has just found an integer sequence  in his right pocket. As DreamGrid is bored, he decides to play with the sequence. He can perform the following operation any number of times (including zero time): select an element and move it to the beginning of the sequence.

What's the minimum number of operations needed to make the sequence non-decreasing?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains an integer  (), indicating the length of the sequence.

The second line contains  integers  (), indicating the given sequence.

It's guaranteed that the sum of  of all test cases will not exceed .

Output

For each test case output one line containing one integer, indicating the answer.

Sample Input

2
4
1 3 2 4
5
2 3 3 5 5

Sample Output

2
0

Hint

For the first sample test case, move the 3rd element to the front (so the sequence become {2, 1, 3, 4}), then move the 2nd element to the front (so the sequence become {1, 2, 3, 4}). Now the sequence is non-decreasing.

For the second sample test case, as the sequence is already sorted, no operation is needed.

用数组b保存理想顺序(升序),由大到小依次找有多少是满足顺序的,这部分不用动,其余的都要移。可手动验证。

#include<iostream>
#include<algorithm>
const int maxn = 1e5+2;
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--){
        int a[maxn],b[maxn];
        int n;
        cin>>n;
        for(int i = 0;i < n;i++){
            cin>>a[i];
            b[i] = a[i];
        }
        sort(b,b+n);
        int l = n-1;
        int num = 0;
        for(int i = n-1;i >= 0;i--){
            while(a[l] != b[i]&&l >= 0)
                l--;
            if(a[l] == b[i]){
                num++;
                l--;
            }
            if(l < 0)
                break;
        }
        cout<<n-num<<endl;
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值