错误:依赖检测失败: mysql-community-libs(x86-64) >= 5.7.9 被 (已安裝) mysql-community-libs-compat-5.7.33-1.el7.x

错误产生环境

删除使用yum方式安装mysql5.7时出现错误

错误描述

[root@localhost mysql]#  rpm -qa | grep -i mysql  
mysql-community-libs-5.7.33-1.el7.x86_64
mysql-community-client-5.7.33-1.el7.x86_64
mysql-community-server-5.7.33-1.el7.x86_64
mysql-community-common-5.7.33-1.el7.x86_64
mysql-community-libs-compat-5.7.33-1.el7.x86_64
[root@localhost mysql]# rpm -e mysql-community-libs-5.7.33-1.el7.x86_64
错误:依赖检测失败:
	mysql-community-libs(x86-64) >= 5.7.9 被 (已安裝) mysql-community-libs-compat-5.7.33-1.el7.x86_64 需要
	mysql-community-libs(x86-64) >= 5.7.9 被 (已安裝) mysql-community-client-5.7.33-1.el7.x86_64 需要

错误原因

使用rpm -e 卸载的顺序问题

解决办法

直接使用以下命令,清除之前安装过的依赖即可

yum remove mysql-libs

如下图,已经卸载完了
在这里插入图片描述

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 黑客帝国 设计师:白松林 返回首页