HDU5670 —— Machine

There is a machine with m(2≤m≤30)m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 
For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed n(1≤n<263)n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15)T(1≤T≤15) indicating the number of test cases. For each test case: 

The only line contains two integers m(2≤m≤30)m(2≤m≤30) and n(1≤n<263)n(1≤n<263).

Output

For each test case, output the colour of m bulbs from left to right. 
R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

题目大意:有一个机器,它有 m(2≤m≤30) 个彩灯和一个按钮。每按下按钮时,最右边的彩灯会发生一次变换。

变换为:1. 如果当前状态为红色,它将变成绿色;

2.如果当前状态为绿色,它将变成蓝色;

3.如果当前状态为蓝色,它将变成红色,并且它左边的彩灯(如果存在)也会发生一次变换.

初始状态下所有的灯都是红色的。

关键:只有当前状态为蓝色其左边的灯泡才变(后一位变三次前一位才会变一次 , 可转换为三进制的求解)。

           注意 n 的数据类型用 long long.

方法:从最右边开始 依次加  n%3  然后 n/3

#include<iostream>
#include<memory.h>

using namespace std;

//red 0  green 1  blue 2
int color[31];
char rgb[]={'R','G','B'};

int main(){
	int t;
	cin>>t;
	while(t--){
		memset(color,0,sizeof(color));
		long long m,n,i,j;	 
		cin>>m>>n;
		for( j=m-1; n ;j--){
			color[j] = n%3;
			n /= 3;
		}
		for(i=0; i<m;i++){
			cout<<rgb[color[i]];
		}
		cout<<endl;
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值