hdoj 【BestCoder Round #81 (div.2)】 5670 Machine



Problem Description
There is a machine with  m(2m30)  coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed  n(1n<263)  times?
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T15)  indicating the number of test cases. For each test case:

The only line contains two integers  m(2m30)  and  n(1n<263) .
 

Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 

Sample Input
  
  
2 3 1 2 3
 

Sample Output
  
  
RRG GR
 
     给出一排彩色的灯,并且他们都连在同一个开关上。这些彩灯有R红,G绿,B蓝三种颜色,当按下开关时,最右边若是红灯,则变为绿灯,如果是绿灯则变为蓝灯,如果是蓝灯将再次变为红灯且它左边相邻的灯也会按照此顺序发生改变。即右边的灯变三次,左边的灯变一次.
代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[33];
char st[3]={'R','G','B'};
int main()
{
	int t ;
	scanf("%d",&t);
	while(t--)
	{
		int m;
		__int64 n;
		int i;
	scanf("%d%I64d",&m,&n);
	for(i=0;i<33;i++)
	str[i]='R';
    for(i=m-1;i>=0;i--)
    {
    	str[i]=st[n%3];
    	n/=3;
	}
	for(i=0;i<m;i++)
	{
		printf("%c",str[i]);
	}
	printf("\n");
	}
}


Problem Description
There is a machine with  m(2m30)  coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed  n(1n<263)  times?
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T15)  indicating the number of test cases. For each test case:

The only line contains two integers  m(2m30)  and  n(1n<263) .
 

Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 

Sample Input
   
   
2 3 1 2 3
 

Sample Output
   
   
RRG GR
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值