7-43 Shuffling Machine (20 point(s))

7-43 Shuffling Machine (20 point(s))

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

 

题目大意:

7-43扑克自动洗牌机(20点)

洗牌是一个用来随机抽出一副扑克牌的过程。因为标准的洗牌技术被认为是软弱无力的,为了避免员工通过洗牌不当而与赌客勾结的"内部工作",许多赌场都使用自动洗牌机。你们的任务是模拟一个扑克自动洗牌机。这台机器洗牌一副54张牌,按给定的随机顺序排列,并重复一定的次数。假设一副扑克牌的初始状态如下:
 

s1,s2,...,s13,
h1,h2,...h13,
c1,c2,...,c13,
d1,d2,...,d13,
j1,j2,

其中" s "代表" spade ",

" h "代表" heart ",

" c "代表" club ",

" d "代表" diamond ",

" j "代表" joker "。

给定的顺序是 [ 1 , 54 ] 中不同整数的排列。如果 i - th 位置的数字是 j 意味着将卡片从 i 位置移动到j位置,例如,假设我们只有5张卡片 S3、 H5、C1、D13 和 J2 。

给定一个洗牌顺序{4,2,5,3,1},结果是:J2,H5,D13,S3,C1。如果我们再重复洗牌,结果会是:C1,H5,S3,J2,D13。

输入规范:

每个输入文件包含一个测试用例。

对于每种情况,第一行包含一个正整数k(≤20),即重复次数。下一行包含了给定的顺序。一行中所有的数字都被一个空格隔开。

输出规范:

对于每个测试用例,将洗牌结果打印成一行。所有的牌都被一个空格隔开,并且线的末端不能有多余的空格。

样本输入:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

样本输出:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
#include <stdio.h>

int main(void) {
    //定义原始卡牌序列(下标从1开始)
    const char *tab[55] = { "\0","S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13","H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13","C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13","D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13","J1","J2" };
    int n, i, input_order[55], order[55], last_order[55];

    scanf("%d", &n);  //输入需要打乱的次数
    for (i = 1; i <= 54; i++) {  //输入需要打乱的顺序
        scanf("%d", &input_order[i]);
    }
    for (i = 1; i <= 54; i++) {  //原始顺序(1到54)
        order[i] = i;
    }
    for (i = 1; i <= n; i++) {
        for (int j = 1; j <= 54; j++) {  //记录打乱前的顺序
            last_order[j] = order[j];
        }
        for (int j = 1; j <= 54; j++) {  //按照给定顺序打乱
            int k;
            for (k = 1; k <= 54; k++) {
                if (input_order[k]==j){
                    break;
                }
            }
            order[j] = last_order[k];
        }
    }
    for (i = 1; i <= 54; i++) {
        if (i == 1) {
            printf("%s", tab[order[i]]);  //第一个输出的卡牌名称前不需要空格
        }
        else {
            printf(" %s", tab[order[i]]);
        }
    }
    printf("\n");

    return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值