7-43 Shuffling Machine(洗牌机)

PTA        中M22秋C、Java入门练习        7-43 Shuffling Machine(洗牌机)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47


Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

代码长度限制        16 KB

时间限制                400 ms

内存限制                64 MB

乱牌是一种用于随机排列一副扑克牌的程序。由于标准洗牌技术被视为薄弱,为了避免“内部工作”,即员工通过不充分的洗牌与赌徒合作,许多赌场采用自动洗牌机。你的任务是模拟洗牌机。机器根据给定的随机顺序洗牌一副54张牌,并重复给定的次数。假定卡片组的初始状态如下:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

其中“S”代表“黑桃”,“H”代表“Heart”,“C”代表“Club”,“D”代表“Diamond”,“J”代表“Joke”。给定的顺序是[1,54]中不同整数的排列。如果第i个位置的数字是j,则表示将牌从位置i移动到位置j。例如,假设我们只有5张牌:S3、H5、C1、D13和J2。给定洗牌顺序{4、2、5、3、1},结果将是:J2、H3、D13、S3、C1。如果我们再次重复洗牌,结果将为:C1、H5,S3、J2、D13。 

输入:

每个输入文件包含一个测试用例。对于每种情况,第一行包含一个正整数K(≤20) 这是重复次数。然后下一行包含给定的顺序。一行中的所有数字都用空格隔开。

输出:

对于每个测试用例,在一行中打印洗牌结果。所有的卡片都用空格隔开,并且在行尾不能有多余的空格。

#include<stdio.h>
#define sum 54

struct pai{								//初始值 
		char name;
		int count;
	}p[65];
struct pai2{							//过程和结果 
		char name;
		int count;
	}p2[65];
	
int main(){
	int n,i,j,z=0;
	int a[54];
	char ch[5]={'S','H','C','D','J',};
	/*输入*/
	scanf("%d",&n);
	for(i=0;i<sum;i++){
		scanf("%d",&a[i]);
	}
	/*初始化牌组*/
	for(i=0;i<5;i++){
		for(j=1;j<14;j++){
			p[z].count=j;
			p[z].name=ch[i];
			z++;
		}
	}
	/*开始交换*/
	for(j=0;j<n;j++){
		for(i=0;i<sum;i++){
			p2[a[i]-1].count=p[i].count;
			p2[a[i]-1].name=p[i].name;
		}
		for(i=0;i<sum;i++){
			p[i].count=p2[i].count;
			p[i].name=p2[i].name; 
		}
	}
	/*输出*/
	for(i=0;i<sum-1;i++){
		printf("%c%d ",p[i].name,p[i].count);
	}
	printf("%c%d",p[53].name,p[53].count);
	return 0;
}

1.用结构体储存字母和数字

2.用c[a[i]]=b[i]进行交换 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
A shuffling machine in C++ can be implemented using an array to represent the deck of cards and using the random number generator to shuffle the cards. Here is a sample code for a shuffling machine: ``` #include <iostream> #include <cstdlib> #include <ctime> using namespace std; const int NUM_CARDS = 52; class ShufflingMachine { private: int deck[NUM_CARDS]; int position; public: ShufflingMachine() { for (int i = 0; i < NUM_CARDS; i++) { deck[i] = i; } position = 0; } void shuffle() { srand(time(NULL)); for (int i = 0; i < NUM_CARDS; i++) { int j = rand() % NUM_CARDS; swap(deck[i], deck[j]); } position = 0; } int dealCard() { if (position >= NUM_CARDS) { shuffle(); } return deck[position++]; } }; int main() { ShufflingMachine shuffler; shuffler.shuffle(); for (int i = 0; i < NUM_CARDS; i++) { cout << shuffler.dealCard() << " "; } cout << endl; return 0; } ``` In this code, the `ShufflingMachine` class represents the shuffling machine. The `deck` array stores the deck of cards, and the `position` variable keeps track of the current position in the deck. The `shuffle` method shuffles the deck by randomly swapping cards. It uses the `srand` function to seed the random number generator with the current time, and the `rand` function to generate random indices for swapping cards. The `dealCard` method deals the next card from the deck. If the deck has been exhausted, it calls the `shuffle` method to shuffle the cards again. In the `main` function, we create a `ShufflingMachine` object and shuffle the cards. Then we deal all the cards and print them out.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

栉风沐雪

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值