1034 Head of a Gang (30 分)(图的遍历,DFS)

92 篇文章 0 订阅

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59

AAA BBB 10

BBB AAA 20

AAA CCC 40

DDD EEE 5

EEE DDD 70

FFF GGG 30

GGG HHH 20

HHH FFF 10

Sample Output 1:

2

AAA 3

GGG 3

Sample Input 2:

8 70

AAA BBB 10

BBB AAA 20

AAA CCC 40

DDD EEE 5

EEE DDD 70

FFF GGG 30

GGG HHH 20

HHH FFF 10

Sample Output 2:

0

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
map<string,int> stringToInt;
map<int,string> intToString;
map<string,int> ans;
int idNumber=1,k;
int stoifunc(string s){
    if(stringToInt[s]==0){
        stringToInt[s]=idNumber;
        intToString[idNumber]=s;
        return idNumber++;
    }else{
        return stringToInt[s];
    }
}
int G[2010][2010],weight[2010];
bool visit[2010];
void dfs(int u,int &head,int &numMember,int &totalweight){
    visit[u]=true;
    numMember++;
    if(weight[u]>weight[head])
        head=u;
    for(int v=1;v<idNumber;v++){
        if(G[u][v]>0){
            totalweight+=G[u][v];
            G[u][v]=G[v][u]=0;
            if(visit[v]==false)
                dfs(v,head,numMember,totalweight);
        }
    }
}
void dfsTrave(){
    for(int i=1;i<idNumber;i++){
        if(visit[i]==false){
            int head=i,numMember=0,totalweight=0;
            dfs(i,head,numMember,totalweight);
            if(numMember>2&&totalweight>k)
                ans[intToString[head]]=numMember;
        }
    }
}
int main(){
    int n,w;
    cin>>n>>k;
    string s1,s2;
    for(int i=0;i<n;i++){
        cin>>s1>>s2>>w;
        int id1=stoifunc(s1);
        int id2=stoifunc(s2);
        weight[id1]+=w;
        weight[id2]+=w;
        G[id1][id2]+=w;
        G[id2][id1]+=w;
    }
    dfsTrave();
    cout<<ans.size()<<endl;
    for(auto it=ans.begin();it!=ans.end();it++)
        cout<<it->first<<" "<<it->second<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值